cancel
Showing results for 
Search instead for 
Did you mean: 

Authentication issue when using Web Gateway in transparent bridge mode

Hi guys.

The Web Gateway(7.3) is configured in transparent bridge mode and the rule set for authentication works only when the proxy is marked in web browser at workstations.

All domain computers with proxy configurations marked can authenticate by NTLM or LDAP without pop up. And computers out of domain and with proxy settings configured can also authenticate, but with one authentication pop up.

The problem happens when the proxy is not configured at these computers, a lot of pop ups appear for the users. I guess that the authenticate is not fixed by the first authentication and a new authentication pop up is sent for each http/https request.

Can anyone help me with this issue?

0 Kudos
2 Replies
pbrickey
Level 11

Re: Authentication issue when using Web Gateway in transparent bridge mode

Hi Renner,


This should help: Support Doc: Authentication Examples by Deployment Method - https://community.mcafee.com/docs/DOC-4384

You need to configure a transparent authentication method using either Time/IP based session or cookie authentication. You then need to 'trust' the MWG's IP by adding in to the Local Intranet Zone. If you are planning on keeping a mixed environment (transparent and direct proxy) I recommend using a different proxy port for each method and adding that criteria to your authentication rules.

-Patrick

Message was edited by: pbrickey on 5/28/13 2:44:09 PM CDT
0 Kudos

Re: Authentication issue when using Web Gateway in transparent bridge mode

Thanks for the help Patrick.

Like you said, I have tryed to use Time/IP Based Session but it does not work properly for computers without proxy settings. When the user authenticates, he can only open HTTP sites. This Rule Set does not work well for HTTPS requests.

But it worked for computers with the proxy marked as well.

Now I need to resolve this new problem. Can you help me?

0 Kudos