cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Former Member
Not applicable
Report Inappropriate Content
Message 1 of 4

AD Authentication keeps prompting

Jump to solution

Hi, we are running McAfee Web Gateway 7.8.2.11.0 (29361).

We are facing an issue with AD Authentication rule sets.
AD Authentication itself for admin console works fine and when testing under Policy - Settings - Authentication - Authentication Test a user is properly validated and reports back the proper username and group memberships.

However, when we import/enable the default "Explicit Proxy Authentication and Authorization" rule set for a test client and make the test user a member of the respective AD group to allow access and start either Chrome or IE on that test machine the page starts to load, but keeps prompting endlessly for username and password.

When we go into Troubleshooting and Rule trace central we do see that the user is properly identified and listing the UID and group membership.

Is there some setting we've missed or could this be related to the permissions that the computer object has which we used for the AD domain join?
Or a client side setting?

Thanks,

JW

1 Solution

Accepted Solutions
pcoates2
Level 8
Report Inappropriate Content
Message 2 of 4

Re: AD Authentication keeps prompting

Jump to solution

Hi JW,

Did you change the authenticator in the authentication rule to an NTLM authenticator as the default rule has the local user database specified as the authentication setting?

 

Thanks,

Pete

View solution in original post

3 Replies
pcoates2
Level 8
Report Inappropriate Content
Message 2 of 4

Re: AD Authentication keeps prompting

Jump to solution

Hi JW,

Did you change the authenticator in the authentication rule to an NTLM authenticator as the default rule has the local user database specified as the authentication setting?

 

Thanks,

Pete

View solution in original post

Former Member
Not applicable
Report Inappropriate Content
Message 3 of 4

Re: AD Authentication keeps prompting

Jump to solution

Thanks Pete, I completely forgot a test rule way down in the chain where I only did a group check and didn't set an authentication rule.....

pcoates2
Level 8
Report Inappropriate Content
Message 4 of 4

Re: AD Authentication keeps prompting

Jump to solution
Happens to all of us! Good luck with your configuration/testing.

Cheers
You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community