cancel
Showing results for 
Search instead for 
Did you mean: 
raiden1221
Level 7

1-2 Minute delay in picking up active proxy when connecting back to our corporate wireless.

Hi All,

This is my first post on the forums.

I currently have a situation at work where when a user for whatever reason disconnects and reconnects from the corporate wireless it takes them a good minute or two before they can browse to external websites. They can browse to internal websites fine i.e. Corporate intranet.

I have checked HKLM --> SOFTWARE --> McAfee --> MCP --> About for the Active Proxy after connecting back to the wireless and I have to refresh for about 1-2 Minutes before it shows the correct proxy and that's when I can browse out.

Currently our LAN settings have it so it automatically detects the settings. I've found when I manually type in the McAfee proxy settings manually it works right away which leads me to believe it could be something with the client itself. We are currently on MCP 1.2.0.8

Has anyone experienced a similar occurrence or provide guidance on troubleshooting that would be much appreciated.

Thanks and Regards

Vincent

0 Kudos
5 Replies
McAfee Employee

Re: 1-2 Minute delay in picking up active proxy when connecting back to our corporate wireless.

Hi Vincent,

Could this be related to this other thread?

Best Regards,

Jon

0 Kudos
raiden1221
Level 7

Re: 1-2 Minute delay in picking up active proxy when connecting back to our corporate wireless.

Hi Jon,

I have followed "I would suggest sticking with "order preference" instead of "fastest proxy" especially when using MWG on premise." However I have been advised that we had this setting already.... Do you have any other suggestions?

0 Kudos
McAfee Employee

Re: 1-2 Minute delay in picking up active proxy when connecting back to our corporate wireless.

Hi Raiden,

From the other post unfortunately there was not a fix for the slowness (except to reduce the number of proxies in the MCP config).

I know development is working on the newest version of MCP and this fix should be included.

Best Regards,

Jon

0 Kudos
raiden1221
Level 7

Re: 1-2 Minute delay in picking up active proxy when connecting back to our corporate wireless.

Appreciate the response Jon. Don't suppose there is any expected time frames for the update ?

Many Thanks

Vincent

0 Kudos
malware-alerts
Level 10

Re: 1-2 Minute delay in picking up active proxy when connecting back to our corporate wireless.

I had opened a case back in August about that.

The problem is 2 folds:

  1. The checks to see which proxy is alive is done in sequence instead of in parallel.
    1. Each check consists of 3 SYN packets sent with increased time-outs. First SYN timesout after 3 seconds, the 2nd after 6 seconds and the 3rd after 12 seconds (21 seconds total).
  2. MCP will systematically check ALL proxies in your list, even if the first one answers and that you are set to use "order preference" (this adds 21 seconds of delay for every proxy that doesn't answer and is a useless check technically speaking when using order preference...)
  3. The captivity portal check also increases the delay by 63 seconds if the captive portal SYN packets are dropped (instead of refused) by your perimeter FW (MCP sends 3x 3 SYN packets to "mcp.webwasher.com").
0 Kudos