Showing results for 
Search instead for 
Did you mean: 
Level 7

Foundstone Update Service Proxy no more working after update to 6.8

Hi guys!

Strange problem indeed...

As you know, on FS appliances there are 2 main Foundstone services running under .\FS user credentials...

Now: while the Foundstone Scan Controller Service starts and runs smoothly, the Foundstone Update Service Proxy fails while starting with the following error: "Error 1069: The Service did not start due to a logon failure"

The strange thing is that BOTH services run logging on with the same user (the default "FS" account created during the installation process), so I can't understand why the first service starts fine while the second one fails...

Any idea?

0 Kudos
2 Replies
Level 13

Re: Foundstone Update Service Proxy no more working after update to 6.8

Hi Douglas,

This is likely a problem with the FS account.

1.  You will need to give the FS account the "logon as service" right and remove it from the "deny logon as a service" right. 

2.  Additionally, you will need to set the password for this account using "Start">"Programs">"Administrative Tools">"Computer Management" MMC snap-in. 

3.  Once you have set the password for FS, log out of the system and log back in using the FS account and password.  This will initialize the user account for this system and allow it to be used for the Foundstone Update Service. 

4.  Log back into the system with your standard administrative account and change the user account for the Foundstone Update Proxy Service to use the new FS account and password you set. 

Verify that the fsupdatelog.txt does not continue to experience the same errors. 

If you continue to have problems, please open a Service Request.

I hope that helps!

0 Kudos
Level 7

Re: Foundstone Update Service Proxy no more working after update to 6.8

Hi Cathy, and first of all thx a lot for your reply!

I solved the issue few minutes ago, after a long WebEx with McAfee Tech Support: the solution provided was associating the Update Proxy service to Local System account (and not to proprietary FS account); once changed that configuration (which maybe was required/configured by older releases) everything went fine and no more errors appeared.

It seems that nowadays, the only service which needs to run with FS user login/permissions is only the Foundstone Scan Controller Service.

I hope by this way the problem is definitively solved!

Messaggio modificato da [Douglas] on 09/03/10 9.43.13 CST
0 Kudos