cancel
Showing results for 
Search instead for 
Did you mean: 

DB Error: Foundstone Database version mismatch

Jump to solution

Hi All,

I'm upgrade foundstone  from 6.8 (fs1000) with sql server 2005 sp4 to 7.5(3100)  with sql server 2005 sp4, i have successfully install fs 7.5 with with sql server 2005...all work fine

but after I try to restore the database, the system said "cannot restore using same db name" so I stop all foundstone services and rename the default faultline name to faultlines

and restore successfully.

then I start all foundstone services..after I try to login to foundstone web I got message "The connection to the McAfee Vulnerability Manager API Service could not be made. Contact your administrator"

I check from log, and got error db version mismatch..

013-05-08 17:02:07-08:00 |  | 2 | ScanEngineSvc | 0x0590 | CommHTTP::PostResource returns (0xa0fbf061)[E_ENGINE_HTTP_CONNECT_FAIL]

2013-05-08 17:02:07-08:00 |  | 2 | ScanEngineSvc | 0x0590 | CommHTTP::PostEngineStatus returns (0xa0fbf061)[E_ENGINE_HTTP_CONNECT_FAIL]

2013-05-08 17:02:25-08:00 |  | 4 | Assessment | 0x0978 | ThreadManager | [P1] | 0 | 0 | 0 | 0 | [TM] | 0 | 10000 | 0 | 0 | 0 | 0 | [Modules] | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | [Process] | 6 | 8360 | 65984 | [System] | 3 | 540 | 0 | [D1] | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 |

2013-05-08 17:02:52-08:00 |  | 4 | FSAPI | 0x086C | Connecting to Foundstone Database (server='W2K3FSNPID01', DBName='faultline', user='sa', NTAuth=0)

2013-05-08 17:02:52-08:00 |  | 1 | FSAPI | 0x086C | DB Error: Foundstone Database version mismatch, version='6.8.79', required='7.5.141'

2013-05-08 17:03:06-08:00 |  | 4 | ScanEngineSvc | 0x0590 | FSScanEngine: Log=0, LogXML=0, ThreadPool_Debug=0

2013-05-08 17:03:06-08:00 |  | 4 | ScanEngineSvc | 0x0590 | Re-posting EngineStatus...

2013-05-08 17:03:07-08:00 |  | 1 | ScanEngineSvc | 0x0590 | CommHTTP::Connect: Unable to connect to (HTTPS)hostname.domain.com:3803. COpenSSLSocket::Connect - tcp connect failed

anyone else ever had the same problem?

any solution?

thanks.

1 Solution

Accepted Solutions
Highlighted
cgrim
Level 13
Report Inappropriate Content
Message 4 of 5

Re: DB Error: Foundstone Database version mismatch

Jump to solution

Hi Benny,

The upgrade guide is on the McAfee download server, you can get the 7.0 installer there also. 

If it being production is a concern you might consider brining up a Win2K3 Virtual Machine  (since 6.8 isn't supported on Win2K8)  to install/upgrade on.  You'd backup the production 6.8 database, and restore it to 6.8 MVM installation on Win2K3 - upgrade that to 7.0.  Backup the 7.0 database. Install 7.0 on Win2K8R2, restore the 7.0 database there , and upgrade that to 7.5.

If you have a specific question I'm happy to address it, but your best option to getting support is to open a support ticket.

-Cathy

4 Replies
cgrim
Level 13
Report Inappropriate Content
Message 2 of 5

Re: DB Error: Foundstone Database version mismatch

Jump to solution

Hi Benny,

Yes, you can't *restore* a 6.8 database to a 7.5 installation. It needs to be upgraded first.

You're best bet is to upgrade the 6.8 to version 7.0 on the FS1000.

Install 7.0 on the Win2k8 system.  Restore the 7.0 database there, then upgrade it to 7.5.

I hope that helps!
Cathy

Re: DB Error: Foundstone Database version mismatch

Jump to solution

Hi cgrim,

thanks for replay,

can you give me short guide upgrade to 7.0 on FS1000 ?

it's risk because already in use in production

thanks.

Highlighted
cgrim
Level 13
Report Inappropriate Content
Message 4 of 5

Re: DB Error: Foundstone Database version mismatch

Jump to solution

Hi Benny,

The upgrade guide is on the McAfee download server, you can get the 7.0 installer there also. 

If it being production is a concern you might consider brining up a Win2K3 Virtual Machine  (since 6.8 isn't supported on Win2K8)  to install/upgrade on.  You'd backup the production 6.8 database, and restore it to 6.8 MVM installation on Win2K3 - upgrade that to 7.0.  Backup the 7.0 database. Install 7.0 on Win2K8R2, restore the 7.0 database there , and upgrade that to 7.5.

If you have a specific question I'm happy to address it, but your best option to getting support is to open a support ticket.

-Cathy

Re: DB Error: Foundstone Database version mismatch

Jump to solution

Hi Cathy,

how about registry that I should backup?

I try to run tool backup wizard from foundstone, but cannot run in w2k3

is there any solutions to restore the registry from w2k3 to w2k8?

thanks beforehand Cathy.

More McAfee Tools to Help You
  • Subscription Service Notification (SNS)
  • How-to: Endpoint Removal Tool
  • Support: Endpoint Security
  • eSupport: Policy Orchestrator
  • Community Help Hub

      New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

    • Find Forum FAQs
    • Learn How to Earn Badges
    • Ask for Help
    Go to Community Help

    Join the Community

      Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

    • Get helpful solutions from McAfee experts.
    • Stay connected to product conversations that matter to you.
    • Participate in product groups led by McAfee employees.
    Join the Community
    Join the Community