Showing results for 
Search instead for 
Did you mean: 
Level 7

failed to create IDispatch error

I just installed McAfee AntiVirus Plus 2011 on a Dell Inspiron laptop and all of a sudden I can't manage the Scann settings.  When ever I run a scan on anything I receive this error.  I am running Windows 7.  I ran the MVT and the response was that it could not find McAfee on this machine.

What is this, some sort of Virus??

Your prompt reply to this message is greatly appreciated.  It appears that this problem has existed for a few years. 

Thanks in advance.

0 Kudos
2 Replies
Level 18

Re: failed to create IDispatch error

There is a thread about this problem HERE and HERE and HERE and HERE.

Do you use a registry cleaner? That usually has something to do with it.

Peacekeeper advised in one of the threads to uninstall and reinstall McAfee. There is also a fix available from McAfee but I gather it has to be requested on a per-case basis.

Message was edited by: Hayton on 17/07/11 23:17:29 IST
0 Kudos
Level 16

Re: failed to create IDispatch error

Hi sivad156,

Were you able to get your issue resolved, if not please follow the steps here in this doc and you should be alright .


0 Kudos