Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 7
Report Inappropriate Content
Message 1 of 13

McAfee won't scan!

I have a similar problem, so I'll piggyback it onto this thread.  Our computer is running XP SP3.  At the beginning of September, I switched from Norton to McAfee.  I used the Norton tools to completely remove Norton.  I bought the installation CD for the three-PC copy of AntiVirus Plus 2010.  Our CD didn't arrive until after our copy of Norton expired, so I downloaded the 30 day trial from McAfee.  Around September 23rd, I attempted to install from the CD, but there were problems with activating for some reason.  Around the 28th, I uninstalled the 30 day trial version and thought I had successfully installed from the CD.

However, I now think that something went wrong with that install that wasn't obvious.  Two days ago I discovered based on symptoms that my computer was infected with some trojan that was causing my searches in Firefox to redirect.  I found yesterday that our copy of IE8 was starting and then shutting down within seconds.  I downloaded Malwarebytes Anti-Malware based on some recommendations, and it found a number of problems.  McAfee real-time scanning also found those problems as Anti-Malware found then.  To be safe, I tried to run a McAfee scan.

When I run McAfee scan, at first it doesn't respond at all.  If I click the "Run a quick scan" or "Run a full scan" link several times, I eventually get a window for the scanner, with the "Completed" area showing "undefined%" completed, and it just sits there like that.  I've left it there for over 20 minutes, and nothing happens.  This is the same whether it's the quick or full scan.  I suspect that the scanning system has not worked since I installed it.

This morning, based on some conversations at this forum, I tried uninstalling and re-installing AntiVirus Plus.  After several attempts, including removing the previous install using the MCPR tool and having to re-register the javascript dll, I thought I had managed to re-install it.  However, now it won't activate (the window appears then quickly disappears).  It says I have until 10/22 to activate.  And the scanning still just sits there.  Based on what you wrote above, I tried downloading and running mvt_en-us.msi.  It ended with a "Fatal Error" "Installation ended prematurely because of an error."  Checking for updates just sits at 0%, though SecurityCenter says the updates are current.

I also tried setting up a scheduled scan for this morning, after the re-install, but it appears to have done nothing.  What should I try next?

One other note.  One recent software install caused problems with other  software.  ITunes 10 autoinstalled a week or so ago, and immediately  killed our copy of Outlook.  It had the symptom that things appeared  then quickly disappeared (a lot like what happens with McAfee  authenticate).  I've followed the instructions elsewhere online to  disable the dll that caused the problem for Outlook, but it's possible  that ITunes is contributing to the problem.  It doesn't seem like that  would cause the scan engine to go nuts, though.

Messages consolidated & branched to own thread by: Ex_Brit for better attention on 07/10/10 11:46:50 EDT AM
12 Replies
Level 16
Report Inappropriate Content
Message 2 of 13

Re: McAfee won't scan!

Hi kjmclark,

Could you please let us know how did you reinstall McAfee programs, through a cd setup or from online account ?
Please navigate to these locations and check if you have any traces of norton still left out

C:\program files

C:\program files\common files.

What is the version of you internet explorer (Click on Help - About internet explorer)


Dinesh K
McAfee Online Community Moderator

Level 7
Report Inappropriate Content
Message 3 of 13

Re: McAfee won't scan!

I can answer part of the question now, and part when I get back home in a few hours.  This morning I tried the following steps:

- Attempted to run a scan, and discovered the scan didn't really do anything.

- Went online and looked up directions for resolving this.

- Found suggestions to re-install.

- Tried to uninstall McAfee using add/remove programs, which seemed to only partially work.  It got part way and hung.

- Tried to find an uninstall program/directory in program files and the windows folder, but couldn't find one.  (Directions for uninstalling IE8 involved this, so I figured I'd try.)

- Found my CD and tried to install from it (attempted to overwrite existing install), but it failed saying there were still components running.

- Rebooted in safe mode.  Tried to manually remove remaining McAfee folders, but some were still in use.  Tried to install from CD but that failed again.

- Looked online and found MCRP tool.  Downloaded it using another computer.

- Ran the MCRP tool.  It said I had to reboot.

- Rebooted to safe mode with networking.  Tried to install from CD, but got an error involving unregistered javascript.

- Looked up the scripting error, which pointed out that I needed to re-register the javascript and vbscript dlls as administrator.

- Registered the dlls as instructed.

- Rebooted to regular XP.  Tried to install using CD, which started an internet install.

- Install seemed to work fine.

- Rebooted.

- Tried to run a scan, but got the same error I was getting in the beginning, "undefined%".

- I had read that for some people, an out-of-date definitions file will prevent scanning, so I tried to update the definitions file.

- Found that updating just sat there as well.

- Tried to correct the activation problem, and found that the activate window immediately disappears.

- Wrote the entry above on my other computer

- Started a full mal-ware scan, and went to work.

If I remember right, there were probably another three or four reboots in that time period, though I don't recall exactly at what step I did them.  I know I only booted into safe mode and safe mode with network support once each.  I rebooted into regular XP because for some reason I had no networking under safe mode with network support.

I'm attempting to install the latest version of IE8.  Actually, I first uninstalled it using directions at MS, and Windows update automatically attempted to re-install the program with the current version.  I can't give you a more precise version number right now, since I don't have a running copy.  The partial install that's there now starts and hangs.  (It's in my startup folder.)  I told windows update to not install any more updates right now.

I'll check on the Norton folders when I get home.


Level 7
Report Inappropriate Content
Message 4 of 13

Re: McAfee won't scan!

Oops.  That's the MCPR tool.  That seemed to work fine, btw.

One other thing I should mention.  When I uninstalled the 30-day version and successfully installed using the CD, it also started an internet download install, and I was able to enter the CD key at that point.  However, I've received a few emails since then saying that my 30-day trial was about to expire and then later that it had expired.  On the 20th I got an email saying it was going to expire on the 27th.  Seems like it was right after that that I did the CD-install.  Then on September 30th, I got another email that my subscription expired on the 27th.  That email was after I had already installed using the CD.

So it's possible that your on-line customer database has two entries for me or something; one for the 30 day subscription, and another for the CD-key one-year subscription.  If the software is attempting to verify my subscription remaining before doing anything, and hitting the entry that expired on the 27th, it's possible that it's deciding that my subscription has expired.  I don't really know how on-line activation works.

Level 7
Report Inappropriate Content
Message 5 of 13

Re: McAfee won't scan!

OK, so there is no Norton directory under c:\program files, c:\program files\common files, or c:\windows.  There is a c:\program files\common files\symantec shared\CCPD-LC folder, with the single file "symlcrst.dll" in it.

There is an iexplore.exe in the c:\program files\internet explorer folder.  That is version 7.0.6000.16850.  Which is funny, since the version I downloaded is named IE8-WindowsXP-x86-ENU.exe, and the one Windows Update is trying to install is "Internet Explorer 8 for Windows XP".


Level 7
Report Inappropriate Content
Message 6 of 13

Re: McAfee won't scan!

I mentioned I ran a malware scan this morning.  The results are a little interesting:

Malwarebytes' Anti-Malware 1.46

Database version: 4754

Windows 5.1.2600 Service Pack 3
Internet Explorer 7.0.5730.11

10/7/2010 7:50:12 PM
mbam-log-2010-10-07 (19-50-12).txt

Scan type: Full scan (C:\|)
Objects scanned: 378251
Time elapsed: 2 hour(s), 19 minute(s), 45 second(s)

Memory Processes Infected: 0
Memory Modules Infected: 0
Registry Keys Infected: 0
Registry Values Infected: 0
Registry Data Items Infected: 2
Folders Infected: 0
Files Infected: 1

Memory Processes Infected:
(No malicious items detected)

Memory Modules Infected:
(No malicious items detected)

Registry Keys Infected:
(No malicious items detected)

Registry Values Infected:
(No malicious items detected)

Registry Data Items Infected:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Security Center\AntiVirusDisableNotify (Disabled.SecurityCenter) -> Bad: (1) Good: (0) -> No action taken.
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Security Center\FirewallDisableNotify (Disabled.SecurityCenter) -> Bad: (1) Good: (0) -> No action taken.

Folders Infected:
(No malicious items detected)

Files Infected:
C:\System Volume Information\_restore{D29674E2-31B4-41A8-9F2D-8427823666BC}\RP1202\A0103352.dll (Trojan.Hiloti) -> No action taken.

The display for this log shows one copy of the Hiloti Trojan (in a system restore file, right?) and two "infected" registry keys, for "Security Center", values "AntivirusDisableNotify" and "FirewalDisableNotify" which are both set to decimal 1.  I get the impression that Anti-Malware expects those values to be 0.

The scan yesterday found:

Registry Keys Infected:
HKEY_CLASSES_ROOT\CLSID\{afd4ad01-58c1-47db-a404-fbe00a6c5486} (Trojan.BHO) -> Quarantined and deleted successfully.
HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Ext\Settings\{afd4ad01-58c1-47db-a404-fbe00a6c5486} (Trojan.BHO) -> Quarantined and deleted successfully.
HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Ext\Stats\{afd4ad01-58c1-47db-a404-fbe00a6c5486} (Trojan.BHO) -> Quarantined and deleted successfully.
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Browser Helper Objects\{afd4ad01-58c1-47db-a404-fbe00a6c5486} (Trojan.BHO) -> Quarantined and deleted successfully.
HKEY_CURRENT_USER\SOFTWARE\wnxmal (Rogue.SecuritySuite) -> Quarantined and deleted successfully.

Registry Values Infected:
(No malicious items detected)

Registry Data Items Infected:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Security Center\AntiVirusDisableNotify (Disabled.SecurityCenter) -> Bad: (1) Good: (0) -> Quarantined and deleted successfully.
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Security Center\FirewallDisableNotify (Disabled.SecurityCenter) -> Bad: (1) Good: (0) -> Quarantined and deleted successfully.

Folders Infected:
(No malicious items detected)

Files Infected:
C:\Recycler\S-1-5-21-1547161642-1715567821-725345543-1003\Dc2076\jjndkdauqiw.exe (RogueSecurityIS) -> Quarantined and deleted successfully.
C:\Recycler\S-1-5-21-1547161642-1715567821-725345543-1003\Dc2077\jslqtwuuqiw.exe (RogueSecurityIS) -> Quarantined and deleted successfully.
C:\Program Files\Shared\lib.sig (Adware.Deepdive) -> Quarantined and deleted successfully.

Level 7
Report Inappropriate Content
Message 7 of 13

Re: McAfee won't scan!

Here's a list of running tasks from this morning.  No change to how things are running btw.  Also, I tried installing the current JRE, but that didn't make any difference.

Image Name                   PID Session Name     Session#    Mem Usage
========================= ====== ================ ======== ============
System Idle Process            0 Console                 0         28 K
System                         4 Console                 0         44 K
smss.exe                    1060 Console                 0        104 K
csrss.exe                   1116 Console                 0      4,708 K
winlogon.exe                1148 Console                 0      4,564 K
services.exe                1192 Console                 0      2,312 K
lsass.exe                   1204 Console                 0      2,964 K
ati2evxx.exe                1372 Console                 0        864 K
svchost.exe                 1388 Console                 0      2,120 K
svchost.exe                 1456 Console                 0      2,296 K
svchost.exe                 1640 Console                 0     22,804 K
svchost.exe                 1684 Console                 0        620 K
svchost.exe                 1752 Console                 0      1,904 K
svchost.exe                 1972 Console                 0      1,504 K
ati2evxx.exe                 244 Console                 0      1,292 K
spoolsv.exe                  480 Console                 0      1,656 K
svchost.exe                  920 Console                 0        824 K
mDNSResponder.exe            916 Console                 0      1,384 K
svchost.exe                 1024 Console                 0        364 K
CTSVCCDA.EXE                1084 Console                 0        164 K
ijplmsvc.exe                1920 Console                 0        348 K
LSSrvc.exe                  1984 Console                 0        212 K
LVPrcSrv.exe                 216 Console                 0      1,148 K
McSvHost.exe                 624 Console                 0     17,372 K
McciCMService.exe           1964 Console                 0      1,456 K
mfevtps.exe                  760 Console                 0     11,512 K
NBService.exe                792 Console                 0      1,180 K
svchost.exe                 1516 Console                 0      2,496 K
ULCDRSvr.exe                1784 Console                 0        136 K
mcshield.exe                1868 Console                 0     76,520 K
mfefire.exe                 2112 Console                 0      1,980 K
nmsrvc.exe                  2132 Console                 0      4,444 K
alg.exe                     2816 Console                 0        572 K
explorer.exe                2876 Console                 0     27,672 K
rundll32.exe                3232 Console                 0        456 K
ONETOU~2.EXE                2360 Console                 0        668 K
soundman.exe                3828 Console                 0      1,408 K
rundll32.exe                3844 Console                 0        420 K
CTSysVol.exe                3852 Console                 0        852 K
NvMixerTray.exe             2412 Console                 0        540 K
MOM.exe                     3944 Console                 0      2,200 K
LVCOMSX.EXE                 3956 Console                 0      3,268 K
mcagent.exe                 4072 Console                 0      1,032 K
ctfmon.exe                  3196 Console                 0        752 K
CCC.exe                     2476 Console                 0      5,828 K
Skype.exe                   3824 Console                 0     15,044 K
SetPoint.exe                3868 Console                 0      3,920 K
boincmgr.exe                2064 Console                 0      2,784 K
KHALMNPR.exe                3456 Console                 0      1,292 K
boinc.exe                   4084 Console                 0      4,148 K
famous_6.11_windows_intel   3724 Console                 0      2,288 K
hadsm3_6.07_windows_intel   3920 Console                 0        556 K
famous_um_6.11_windows_in   3460 Console                 0     30,656 K
hadsm3_um_6.07_windows_in   1576 Console                 0     43,688 K
skypePM.exe                 5984 Console                 0      4,996 K
wuauclt.exe                 3240 Console                 0      3,312 K
mcsync.exe                  1736 Console                 0      2,832 K
MpfAlert.exe                4552 Console                 0      3,492 K
AppleMobileDeviceService.   3676 Console                 0        360 K
MsMpEng.exe                 4596 Console                 0     28,564 K
jqs.exe                     5100 Console                 0        872 K
firefox.exe                 1952 Console                 0    154,660 K
plugin-container.exe        5712 Console                 0     10,120 K
BrowserPlusCore.exe         4844 Console                 0      1,248 K
mcupdate.exe                3600 Console                 0      1,324 K
mcupdmgr.exe                5608 Console                 0      1,620 K
wmiprvse.exe                4176 Console                 0        716 K
cmd.exe                     2456 Console                 0      2,928 K
wmiprvse.exe                 280 Console                 0      6,408 K
tasklist.exe                2868 Console                 0      5,012 K

Level 7
Report Inappropriate Content
Message 8 of 13

Re: McAfee won't scan!

Hello everybody.

Sadly I cant help out you kjmclark...

I am having same problem for few weeks already and have been checking solutions online, nothing worked I think everything is related with TuneUp Utilities but somehow I cant uninstall them, and the tools delivered here to check the McAfee software are not running properly (same set up failure)

So I have decided to remove McAffee Antivirus Plus completely and then reinstall it, might work for me, who knows. By the way... Uninstalling will mean I will have back a license to use or I will "lose it" and will need to re-install the software using one of the licenses I have unused right now?.

I will keep you informed if I get any progress.

Re: McAfee won't scan!

Patxi that sounds like a good idea to uninstall and reinstall McAfee.  Use the MCPR removal tool after a normal uninstall, available through Useful Links above and then reboot.   Then try the new installation.

FYI Tune Up Utilities is not a very good idea...any kind of registry cleaner or optimizer will eventually mess up your system and installed applications as they invariably remove good stuff along with the trash.

I see from the web that removing it is a problem for many so you might want to try their support:

Or Google "Remove Tune Up Utilities" minus the "".

Level 7
Report Inappropriate Content
Message 10 of 13

Re: McAfee won't scan!

Many thanks for attention Ex_Brit.

I did uninstall Tune up Utilities with Totall Uninstall software, seemed to work ok so far.

First attenpt to uninstall McAfee software and to my surprise when I click the uninstall boutton, trough control panel on windows XP, nothing happens.... Should I manually delete all the McAffee files and then use the removal tool? Please need clues!

Thanks in advance

How Many Badges Can You Collect?
Ready for a little competition? Members like you are earning badges and unlocking perks for their helpful answers. Are you? Click here to find out.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community