cancel
Showing results for 
Search instead for 
Did you mean: 

Windows 7 Enterprise Sysprep (Fails after Install)

I am setting up images of Win 7 enterprise.

I have VSE 8.8 on them and if I don't add the McAfee agent and all the other modules (policy auditor, hips, etc) it will sysprep and install fine via WDS.

If I put all the other McAfee stuff on the machine it will sysprep fine, but once I capture the image (.wim) and go to deploy it, it will install and then when it reboots to finish applying registry settings it fails, says to reboot and try again, and then it gets stuck in this loop.


With all the McAfee stuff installed I am going into the registry and removing the agentGUID key.  I did get a log with some registry errors that I can share, but I am not sure what I need to change from here.  I need to get this image to include all the McAfee add ons.

Any ideas?  I've also tried clearing out the mac address setting as well but it still does the same thing.

8 Replies
Reliable Contributor exbrit
Reliable Contributor
Report Inappropriate Content
Message 2 of 9

Re: Windows 7 Enterprise Sysprep (Fails after Install)

Moved to VSE for better support.

Re: Windows 7 Enterprise Sysprep (Fails after Install)

If it makes any difference its the Army Golden Master image I'm using.  I'm wondering if something they tweaked when making the baseline image that is available to create our local image from is causing this issue.  I'm clueless but I need to get this working so we can deploy new systems.

McAfee Employee wwarren
McAfee Employee
Report Inappropriate Content
Message 4 of 9

Re: Windows 7 Enterprise Sysprep (Fails after Install)

You have to disable Access Protection until the image building is complete.

See KB76867. I believe this is what you're running into.

William W. Warren | S.I.R.R. | Customer Success Group | McAfee

Re: Windows 7 Enterprise Sysprep (Fails after Install)

I'll give it a try.


I just tried removing the agent before running sysprep, and after it captured the image, when it rebooted, it failed.  I'll disable access protection and see if it makes a difference.

The error I'm getting is after imaging a machine with my image, it reboots and says Starting windows, then setup is updating registry settings, then setup is starting services, then it fails and gives a pop up box that says "Windows could not finish configuring the system. To attempt to resume configuration, restart the computer."


I do, and it keeps happening over and over.


If I don't put the Policy auditor, host intrustion prevention, asset baseline monitor, policy auditor content update, and policy auditor on it, it will install fine on other computers.


Once I get the rest of the McAfee stuff installed, then the image won't work once sysprepped.

I'm seriously about to throw this thing out the window.  The old image we have that works, has all the McAfee stuff pre-installed.  I don't know how that last guy got it to work but it won't work for me, and we are supposed to release new images quarterly.  The current working one we use is over a year old.

Re: Windows 7 Enterprise Sysprep (Fails after Install)

Once I have the agent on the system and the service running, I can't go into VSE and stop the access protection, its grayed out.  I can't stop the McAfee service or it won't work.


I did get the system to properly sysprep and install using only VSE 8.8 and the agent.  It took it a while to update its computer name in the "about" section by itself but I came in this morning and it did.


The problem is that I need to be able to include all the plug-in's into the image and I can't.

it_sec
Level 7
Report Inappropriate Content
Message 7 of 9

Re: Windows 7 Enterprise Sysprep (Fails after Install)

How did you get the Asset Baseline Monitor to install? I have tried every which way, I am running Windows 7 x64...It installed fine on the previous image as well, but I am also at a loss on how he was able to get the ABM installed.

Re: Windows 7 Enterprise Sysprep (Fails after Install)

Try this:

Go to the McAfee tray icon, click and go to Quick Settings. Turn off HIPS and NIPS. Try the image again.

I was having the same issue as you and this was a workaround, even though HIPS and NIPS should be turned on. I am not sure if they turn back on automatically if you have EPO, but its at least worth a shot.

Highlighted
shocko
Level 9
Report Inappropriate Content
Message 9 of 9

Re: Windows 7 Enterprise Sysprep (Fails after Install)

VSE 8.8 Patch 9 resolves most sysprep issues whilst leaving OAP enabled

More McAfee Tools to Help You
  • Subscription Service Notification (SNS)
  • How-to: Endpoint Removal Tool
  • Support: Endpoint Security
  • eSupport: Policy Orchestrator
  • Community Help Hub

      New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

    • Find Forum FAQs
    • Learn How to Earn Badges
    • Ask for Help
    Go to Community Help

    Join the Community

      Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

    • Get helpful solutions from McAfee experts.
    • Stay connected to product conversations that matter to you.
    • Participate in product groups led by McAfee employees.
    Join the Community
    Join the Community