cancel
Showing results for 
Search instead for 
Did you mean: 
korax
Level 7
Report Inappropriate Content
Message 1 of 4

Virusscan 8.7i patch 1 won't install

On several machines patch 1 won't install.
The install exits stating that you already have a more recent version installed which is not correct.

This is what appears in the log file:

Product: McAfee VirusScan Enterprise - Update 'Patch 1 for McAfee VirusScan Enterprise 8.7' could not be installed. Error code 1603.

Windows Installer installed an update. Product Name: McAfee VirusScan Enterprise. Product Version: 8.7.0. Product Language: 0. Update Name: Patch 1 for McAfee VirusScan Enterprise 8.7. Installation success or error status: 1603.

Note: 1: 1729
Product: McAfee VirusScan Enterprise -- Configuration failed.

Windows Installer reconfigured the product. Product Name: McAfee VirusScan Enterprise. Product Version: 8.7.0. Product Language: 0. Reconfiguration success or error status: 1603.

Attempting to delete file C:\Users\u0051114\AppData\Local\Temp\79d615.msp
Grabbed execution mutex.
Cleaning up uninstalled install packages, if any exist
Attempting to delete file C:\Users\u0051114\AppData\Local\Temp\79d615.msp
Unable to delete the file outside of the engine. LastError = 2
MainEngineThread is returning 1603
3 Replies

RE: Virusscan 8.7i patch 1 won't install

Try doing a repair (either through add/remove programs or virusscan console) and then install patch 1.

Post your results and we'll go from there.

RE: Virusscan 8.7i patch 1 won't install

Could you check the registry key
[HKEY_LOCAL_MACHINE\SOFTWARE\McAfee\DesktopProtection]
and look for a value Patch_x. It corresponds to the Patch level of VirusScan 8.7.
If it's there, then it could be that during the upgrade from VSE 8.5 to 8.7 this value hasn't been reset correctly.

In this situation, try deleting this value and deploy the patch again.
korax
Level 7
Report Inappropriate Content
Message 4 of 4

RE: Virusscan 8.7i patch 1 won't install

ralfrino

I checked the registry and there was a Patch_5 entry which referred to virusscan 8.5. The product version entry also referred to 8.5 while I already had 8.7 on my system. Seems that the upgrade fails to correct change the registry.

Anyway I removed Patch_5 and patch 1 installed correctly

Thanks
More McAfee Tools to Help You
  • Subscription Service Notification (SNS)
  • How-to: Endpoint Removal Tool
  • Support: Endpoint Security
  • eSupport: Policy Orchestrator
  • Community Help Hub

      New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

    • Find Forum FAQs
    • Learn How to Earn Badges
    • Ask for Help
    Go to Community Help

    Join the Community

      Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

    • Get helpful solutions from McAfee experts.
    • Stay connected to product conversations that matter to you.
    • Participate in product groups led by McAfee employees.
    Join the Community
    Join the Community