cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
suman_rak
Level 7
Report Inappropriate Content
Message 1 of 11

VirusScan OnAccess Scanner not getting enabled

I have been performing R&D from long time on this issue. But, did not achieve any success. VirusScan OAS is in disabled state for many machines. And when I unlock the VSE console and try to enable OAS, it does not gets enabled. Did everything from stopping services to disabling Access Protection. Nothing works except for a VSE reinstallation which I the last option I wanna do.

Someone, please suggest ways to remediate this issue. What might cause this weird behavior?

Thanks in advance!

10 Replies
system48
Level 9
Report Inappropriate Content
Message 2 of 11

Re: VirusScan OnAccess Scanner not getting enabled

Can you check the value of a registry key on one of these systems? 


32-Bit OS

Location: HKLM\Software\McAfee\DesktopProtection

Key: OASState

64-Bit OS

Location: HKLM\Software\Wow6432Node\McAfee\DesktopProtection

Key: OASState

suman_rak
Level 7
Report Inappropriate Content
Message 3 of 11

Re: VirusScan OnAccess Scanner not getting enabled

Hi System48,

The value for OASState is 2.

ansarias
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 4 of 11

Re: VirusScan OnAccess Scanner not getting enabled

Try to redeploy VSE from ePO console on some machines and add below command under command line in deployment task.

REINSTALLMODE=amus /q (Install both program and registry files)


suman_rak
Level 7
Report Inappropriate Content
Message 5 of 11

Re: VirusScan OnAccess Scanner not getting enabled

I dont want to redeploy VSE. I want this as the last option. Need to know the root cause behind this issue which I am unable to find.

ansarias
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 6 of 11

Re: VirusScan OnAccess Scanner not getting enabled

OAS was disable automatically or it was happen after upgrade?

When it was working perfectly.

suman_rak
Level 7
Report Inappropriate Content
Message 7 of 11

Re: VirusScan OnAccess Scanner not getting enabled

It was disabled automatically. Not after the upgrade

system48
Level 9
Report Inappropriate Content
Message 8 of 11

Re: VirusScan OnAccess Scanner not getting enabled

Do you have the access protection policy enabled for McAfee processes, files and registry settings?

Re: VirusScan OnAccess Scanner not getting enabled

Resolved for me

I was facing similar issue on windows 2003 server.  I removed VSE 8.8 and redployed. but getting OAS disabled.Aslo tried deleting McShied service.but no luck. Finally, I modiefied registry entry as below

HKLM\Software\McAfee\DesktopProtection

OASState=3

this enabled the ON Access Scanner in windows 2003 server.

Re: VirusScan OnAccess Scanner not getting enabled

Morning suman,

You could run the McAfee getsusp and see if the Machine could be infected.

To download the getsusp go to:

http://www.mcafee.com/es/downloads/free-tools/getsusp.aspx

If you do not know how to interpretate the logs just upload it in here and we can check it.

Best regards,

Jose


You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community