cancel
Showing results for 
Search instead for 
Did you mean: 

VS 8.8 not scanning

Hi,

We have VS 8.8 with Patch 1 installed deployed via ePO on our network and we can't get a virus scan to run on most of our machines.

If we right-click the agent icon then 'Scan computer for...' > Threats we get errors saying Scan32.exe is a bad image file. BUT not on all machines, and even on ones that have shown error, do not all the time.

If we open virusScan console, highlight Full scan and click the 'play button', nothing happens.

If we open Full scan settings and click start we keep getting a box popping up saying 'you changed scan settings do you want to save them' even when we havent. click yes to save and try and start it again, the same box pops up.

Anybody come across this before?

Thanks!

9 Replies
hemantk
Level 12
Report Inappropriate Content
Message 2 of 10

Re: VS 8.8 not scanning

Hello,

can you please post the screenshot ???.........

Re: VS 8.8 not scanning

Thanks for the repl, and apologies for no screenshot.

"If we right-click the agent icon then 'Scan computer for...' > Threats we get errors saying Scan32.exe is a bad image file. BUT not on all machines, and even on ones that have shown error, do not all the time."

This is the error when we do that particular thing

untitled.JPG

Highlighted
bakerrl
Level 11
Report Inappropriate Content
Message 4 of 10

Re: VS 8.8 not scanning

See KB Below

Bad Image: The application or DLL C:\WINDOWS\system32\msi.dll is not a valid Windows image

https://kc.mcafee.com/corporate/index?page=content&id=KB73521&actp=search&viewlocale=en_US&searchid=...

Re: VS 8.8 not scanning

Thanks for the reply.

unfortunately the updated msi hotfix that KB refers to doesn't work.

bakerrl
Level 11
Report Inappropriate Content
Message 6 of 10

Re: VS 8.8 not scanning

Did you run sfc /scannow  ?

Re: VS 8.8 not scanning

Yeah i did. no luck. didnt find any problems..

bakerrl
Level 11
Report Inappropriate Content
Message 8 of 10

Re: VS 8.8 not scanning

The only thing I can think of is a full uninstall and reinstall.

Message was edited by: bakerrl on 12/6/11 8:46:23 AM EST
da.ho
Level 7
Report Inappropriate Content
Message 9 of 10

Re: VS 8.8 not scanning

Had the same problem...

sfc /scannow works

deinstall/install not...

(thx)

alexn
Level 14
Report Inappropriate Content
Message 10 of 10

Re: VS 8.8 not scanning

If nothing works, try the last solution in this KB.

To disable the Common Standard Protection AP rule that prevents McAfee processes from being hooked:

  1. Click Start, Programs, McAfee, VirusScan Console.
  2. Double-click Access Protection.
  3. Select Common Standard Protection.
  4. Deselect both the Block and Report entries for Prevent hooking of McAfee processes (this is enabled by default).
  5. Click OK and exit VirusScan Console.

Thnx

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community