cancel
Showing results for 
Search instead for 
Did you mean: 

Uninstall of VSE fails with unable to find valid repository.

Hello All,

I am running into an issue with VSE 8.8 Patch 4. I am trying to upgrade from VSE patch 4 to patch 7. First I upgraded the McAfee Agent to 5.0.3.316 as agent 4.8.0 is not compatible with patch 7. I then proceeded to upgrade to patch 7 for those clients with MA 5.0.3 installed. Only about 10% were able to apply the Patch 7 install. The tasks showed as completed Patch 7 install but the computers still showed Patch 4 installed. So I tried to do a uninstall of Patch 4. This way I could try Patch 7 again with a clean install. However, I got the following error in my task log.

Server Task Log Information

Name:Computer Name: TEST-PC01
Source:Run Client Task
Start Date:7/1/16 1:22:58 PM
Duration:1 minute
User Name:testuser
Status:Failed
Parent Task Name:RunNow Task For : Uninstall (WIN) Virus Scan Enterprise Patch 4

Log Messages

7/1/16 1:22:58 PMStarted: Sent Run Now task "Uninstall (WIN) Virus Scan Enterprise Patch 4" to "TEST-PC01"
7/1/16 1:23:05 PMRun now task Uninstall (WIN) Virus Scan Enterprise Patch 4 received.
7/1/16 1:23:06 PMRun now task started.
7/1/16 1:24:37 PMRun now task Uninstall (WIN) Virus Scan Enterprise Patch 4 failed.
Details: Product "VIRUSCAN8800" installation failed, reason "Content download error".
Product "VIRUSCAN8800" uninstallation succeeded.
Deplyment/Update task failed, reason "Unable to find valid repository"..

When I look at the computer, it does show the product as removed, but I don't understand how it succeeded, yet says it failed. I then proceeded to install Patch 7, which appears to have worked.

Any idea why ePO 5.3.2. does this? Does anyone else get these "False Failures"?

3 Replies

Re: Uninstall of VSE fails with unable to find valid repository.

Hi,

I have the same Problem with serveral clients. VSE 8.8.1445 is installed an I try to run an uninstall task because the install task for VSE 8.8.1522 doesn't work for these clients (Details: Product "VIRUSCAN8800" installation failed, reason "Content download error".) Normally I can upgrade to VSE 8.8.1522 without any problems.

EPO Version 5.3.2 and the agent is 5.0.3.316.

Re: Uninstall of VSE fails with unable to find valid repository.

what are the products are installed. Did you follow the below article ?

https://kc.mcafee.com/corporate/index?page=content&id=SB10151

Reply to this thread with Addition input.

Br,

Ajay

Re: Uninstall of VSE fails with unable to find valid repository.

Hello,

That article is not related to this issue exactly. My issue is I get errors when running an uninstall task for VSE 8.8.1247. I am running an uninstall task because the install task for VSE 8.8.1522 does not seem to install on top of 1247. In the past I have been able to deploy the new version of VSE which would remove the old version and install new one without any issues. Now, it fails so I have to do an uninstall first. The big issue here is the job reports as failed, but looking at the logs I posted, it shows the uninstall succeeded. I have confirmed the product is removed from the system and I am able to install the new version afterwards.

I want to know what is causing the "Content download error" & "Unable to find valid repository" errors so I can fix it.