cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to install new mcafee product

Hi All.

I recently bought a second hand laptop online and I bought 'McAfee® Total Protection' and tried to install.

But I got a message saying : "Cannot proceed as there enterprise products detected".

So when I went to Control Panel --> Add/Remove Programs I saw, "Mcafee Viruscane Enterprise". 

But I went into the Program File folder, and there is a McAfee folder but there is only 'Web Advisor' inside it. So I tried to uninstall it from the 'Add/Remove programs'.

But I got a messag saying:

"The specified resource language ID cannot be found in the image file.

McShield.dll: The system cannot find the file specified".

I contacted consumer mcafee customer care and explained the error to them and  they said this is related to enterprise mcafee, please contact them. I got phone contact for Enterprise Mcafee and when I tried to call them up, I am asked to enter some code, but I dont have one. 

I tried the tools like MCPR.exe

SO, I am basically stuck with not being able to install a new one and unable to uninstall .

Any help is greatly appreciated.

More McAfee Tools to Help You
  • Subscription Service Notification (SNS)
  • How-to: Endpoint Removal Tool
  • Support: Endpoint Security
  • eSupport: Policy Orchestrator
  • Community Help Hub

      New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

    • Find Forum FAQs
    • Learn How to Earn Badges
    • Ask for Help
    Go to Community Help

    Join the Community

      Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

    • Get helpful solutions from McAfee experts.
    • Stay connected to product conversations that matter to you.
    • Participate in product groups led by McAfee employees.
    Join the Community
    Join the Community