cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 8
Report Inappropriate Content
Message 1 of 2

Scan32 and scan64 not scanning sub folders

Jump to solution

Trying to initiate scan via batch file and have included /SUB but only the target folder is scanned, not its sub folders.

1 Solution

Accepted Solutions
Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 2

Re: Scan32 and scan64 not scanning sub folders

Jump to solution

Hi @Rockb 

Thank you for your post. Good question. Looks like /SUB is a supported command for McAfee VirusScan Command Line Scanner. If you are using VSE's Scan32 or Scan64 to perform a scan via command line, try ALL parameter, I can confirm that it works fine.

I have added a screenshot to this for your kind reference.

What I have done:

  1. I have the folder open for which I had launched the task (The McAfee Agent folder under programdata)
  2. I have launched Scan32.exe using CMD as Administrator and run it using the parameters: ALL and FilePath and also logging enabled.
  3. Just to confirm the configuration that is being applied here, I have removed autoexit parameter from the command and ran it.
  4. I have clicked on properties windows to show you the configuration as well where you can see that Include sub folders is checked and the path is confirmed as well.

I sincerely hope this resolves your query.

*Note: Here is the Product Guide so that you can refer to the supported list of commands.

Was my reply helpful?
If you find this post useful, Please give it a Kudos! Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!

Thanks and regards,
Adithyan T

View solution in original post

1 Reply
Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 2

Re: Scan32 and scan64 not scanning sub folders

Jump to solution

Hi @Rockb 

Thank you for your post. Good question. Looks like /SUB is a supported command for McAfee VirusScan Command Line Scanner. If you are using VSE's Scan32 or Scan64 to perform a scan via command line, try ALL parameter, I can confirm that it works fine.

I have added a screenshot to this for your kind reference.

What I have done:

  1. I have the folder open for which I had launched the task (The McAfee Agent folder under programdata)
  2. I have launched Scan32.exe using CMD as Administrator and run it using the parameters: ALL and FilePath and also logging enabled.
  3. Just to confirm the configuration that is being applied here, I have removed autoexit parameter from the command and ran it.
  4. I have clicked on properties windows to show you the configuration as well where you can see that Include sub folders is checked and the path is confirmed as well.

I sincerely hope this resolves your query.

*Note: Here is the Product Guide so that you can refer to the supported list of commands.

Was my reply helpful?
If you find this post useful, Please give it a Kudos! Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!

Thanks and regards,
Adithyan T

View solution in original post

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community