cancel
Showing results for 
Search instead for 
Did you mean: 

Mcshield.exe - Application Error Popup

Running 8.7i, todays dat, EPO 4.0.0.1345 on XP SP2 - I have 2 computers with the same issue.

McAfee McShield service fails to start.

Popup is: The instruction at 0x00409f5f referenced memory at 0x00000014. The memory could not be read.

Application Log: 5019 Error

VSCORE.14.1.0.447
Exception Code: 0xc0000005
Exception Address: 0x00409f4f
Exception Parameters: 2
Param 1 = 00000000
Param 2 = 0x00000014

More information:
Exception in memory scanner thread.



Problem: McAfee corrupt driver.

1) control panel- uninstall VSE
2) Go to device manager - show all hidden deviced- uninstall all Mcafee drivers as well as the drivers in yellow color ( problem drivers)
3) Uninstall agent ( frminst /forceuninstall )
4) Delete all Mcafee registry entries
Reinstall VSE- It will be installed succesfully.


Pushed back down agent, and problem comes back. Problem is coming from EPO server. Contacting McAfee support for more help.
I am up to 5 PC's with the same problem now! Looking for help.
3 Replies
alexdd
Level 7
Report Inappropriate Content
Message 2 of 4

RE: Mcshield.exe - Application Error Popup



Did you scan the system already?
I have the same issue on a system where I don't have the ePO agent installed yet...
Currently working on it Smiley Sad

and.. Are you using the latest EPO patches? (Patch 4 already)
alexdd
Level 7
Report Inappropriate Content
Message 3 of 4

RE: Mcshield.exe - Application Error Popup



I had this issue on 4 diffent systems and .. Each of these had been infected by the Conficker/b virus. (detected but unremovable for McAfee scan).

I used the Microsoft (yes - those guys Smiley Tongue)null Malicious Software Removal Tool to remove the problem after which the system worked fine again.

SO... Regardless of the Error: Click on the McAfee Icon and start a full system scan (this will work!!)
VHolt
Level 7
Report Inappropriate Content
Message 4 of 4

0x00409f5f

I also have the same issue on 0x00409f5f. Client XP SP2. ePO 4.0 with patch 3. VSE 8.7i.

I am downloading patch 4 to see if that helps.
I may also try to go to SP3 for XP, but this client is tied to some machinery so I am not sure if that is the best thing for me at the moment.

did you recieve any feedback from McAfee yet?