cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Re: McAfee OAS: Disabled problem

Now....Tony's answer seems to have sorted it.  I downloaded the patch (once I found it...thank you so much for the comprihensive list of how to get to it) and installed it exactly as described in the text document.  The 'Red Circle' has gone and the shield now shows as "McAfee OAS: enabled"

So, job done?  Well not quite!!

This doesn't really bother me as it all seems to be working fine, but if I right click on the shield and select "About VirusScan Enterprise" it shows "Installed patches:  None", even after a reboot.  I went to install the patch again in case it hadn't worked but I got a message saying "A later version of the McAfee product line is already installed...", so I must be up to date!

Any idea why it doesn't say "Installed patches:  8"?

Cheers
Glenn

tonyb99
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 12 of 18

Re: McAfee OAS: Disabled problem

the patches sometimes screw up and dont create the reg keys...

do you have the patch 8 string key key in this location?

HKEY_LOCAL_MACHINE\SOFTWARE\McAfee\DesktopProtection\Patch_8

I havnt experimented with altering the keys if I get this I usually just remove vse and reinstall ( with your grant you could install vse with patch 8 included from the main link on the page you accessed prev.)

wwarren
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 13 of 18

Re: McAfee OAS: Disabled problem

When you chose VirusScan's "About" window, the Patch number only displays if patch validation is successful.

In other words, if you believe you installed patch 8, and you do not see Patch 8 reporting in that About window, then something is wrong with the patch 8 installation.

It may be only a reboot that is needed, so do that first. But if still not displaying Patch 8 then there's a problem. One or more files did not get updated.

Reinstalling the product is good.

You can also try reinstalling the patch - but you have to specify FORCEMSP=True via the commandline to bypass installation checks.

e.g. go to the folder where Patch 8 files are, then use: setup.exe FORCEMSP=True /qb

William W. Warren | S.I.R.R. | Customer Success Group | McAfee
wwarren
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 14 of 18

Re: McAfee OAS: Disabled problem

You definitely want to be on Patch 8 if using VSE 8.5i.

For the symptom you report, whenever the on-access scanner is failing - whatever the circumstance - you can inspect the Application Event log for "McLogEvent" entries.

If there are "McLogEvent" entries with an event ID higher than 5000 then that is indicative of a problem. The details of the event will give further clues as to what the problem is.

You could then search the knowledgebase for more info on the event ID or the message in the Event details, or post it here

William W. Warren | S.I.R.R. | Customer Success Group | McAfee
kthomas
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 15 of 18

Re: McAfee OAS: Disabled problem

Our team is here to assist in working with the community in an effort to ensure common issues are documented. Although I was able to locate an article for this issue using the good solution provided by William, however the article I found was only tagged with VSE 8.0. Our team will work to have a new article created to cover this topic for all versions of VSE.  We are finding that the community is good resource to identify such issues and have the articles updated. The new article will cover ensuring the latest patch is installed and the final solution if that fails provided by William.

The article I was referring to with the similar issue was documented in KB58166.

Kevin

Go to the McAfee ServicePortal and search for KnowledgeBase article KB58166. (KB title: After Patch 11 is applied, no patch version displays for VirusScan Enterprise)

NOTE:You can access the KnowledgeBase anonymously, but some articles are available only to logged in users

Kevin
Knowledge Analyst (Global Online Services)
Web: http://mysupport.mcafee.com

Re: McAfee OAS: Disabled problem

tonyb99...I do seem to have the patch 8 string key (HKEY_LOCAL_MACHINE\SOFTWARE\McAfee\DesktopProtection\Patch_8) (snapshot attached)

William...Your FORCEMSP=True command worked in as much as I was able to run the 'setup.exe' file again.  However, even after a restart I still don't seem to have any patches loaded (according to the dialogue box, which I have attached).

I have just downloaded patch 8 again in case it was the download that was corrupted.  I installed the setup file by using "setup.exe FORCEMSP=True /qb" which allowed the install to go ahead but I still get no notice on the dialogue box that the patch has been loaded (still shows "Installed Patches:  None").

I don't know if this will have any difference but when I downloaded the patch, the only way I could download it was to right click on the link and click 'Save target as".  I don't think this should make any difference as I seem to have all of the files (see attached, showing zip file and extracted files).

Any further ideas would be appreciated.


Regards

Glenn

wwarren
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 17 of 18

Re: McAfee OAS: Disabled problem

You're dong all the right things, so don't worry about that.

The patch validation is still failing though.

If you're up for it, crack open the Patch readme and locate the section showing the file names and their versions...

Then look at the installed files on your system, and see if you can spot what file(s) are not matching the version number decribed in the readme.

It's helpful to change your Windows Explorer columns to include the "File Version" column, so you don't have to go to the Properties of each file - that would be annoying.

If you run our MER tool, from mer.mcafee.com, one of the files it creates is a .csv listing the version of each file we install.

We know there are one or more files not being updated. Even once we find them, the next challenge is understanding why they're not being updated.

It's probably best to engage Support at this time.

William W. Warren | S.I.R.R. | Customer Success Group | McAfee

Re: McAfee OAS: Disabled problem

In the end I did the sensible thing!  I uninstalled the software, reinstalled it and downloaded the latest patch.

Hey presto, it's ll fine now!

I would like to thank you all for your time and effort with this problem, it is very much appreciated.

Regards

Glenn

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community