cancel
Showing results for 
Search instead for 
Did you mean: 

McAfee OAS: Disabled problem

Hi,

I am running VirusScan Enterprise 8.5.0i on a Windows Vista Business platform.  It is a standalone PC, not connected to a network/ePO.

The shield icon shows in the system tray with a red circle with a red line through it.  If I hover over the shield it shows "McAfee OAS: disabled".  If I right click on the shield and choose "Enable On-Access Scan", the red circle disappears for about 5 seconds and then reappears again.

This also causes an error within Windows Security Alerts stating that McAfee is turned off!  If I click on the "Turn on now" button, nothing happens!

Does anybody have any idea on how I can sort this out?

Regards

Glenn

17 Replies
tonyb99
Level 13
Report Inappropriate Content
Message 2 of 18

Re: McAfee OAS: Disabled problem

Can you advise what patch level of vse 8.5 you are running

Re: McAfee OAS: Disabled problem

Installed Patches: None

I have looked but I can't find where I can download the patches from

Highlighted
tonyb99
Level 13
Report Inappropriate Content
Message 4 of 18

Re: McAfee OAS: Disabled problem

The patches are only available from the Mcafee business downloads section with a grant number thats provided to licenced customers, you need to obtain the VSE patch 8 from the licence holder of your installation.

As some incentive VSE 8.5 with no patches ran so badly that patch 1 was released urgently afterwards, If you cant get a patch above at least 6 I would recommend you look at another scanner as the base level software will not be doing a good job and will be thrashing your PC.

Thanks

Re: McAfee OAS: Disabled problem

Ok, well I have a grant number and all that, but I still can't seem to find where I can download this patch!  Treat me like I'm an idiot (no comments please!!), could you point me to where the latest patch is that I need please.  Struggling here!!

Cheers

Glenn

JThomas
Level 9
Report Inappropriate Content
Message 6 of 18

Re: McAfee OAS: Disabled problem

Login to https://secure.nai.com/apps/downloads/my_products/login.asp with your grant #.

Once you are viewing the products available,click on the version of VSE you have.

Once you agree to the terms, click on the patches tab.

VSE 8.5 P8.zip is available.

tonyb99
Level 13
Report Inappropriate Content
Message 7 of 18

Re: McAfee OAS: Disabled problem

go here: http://www.mcafee.com/uk/enterprise/downloads/index.html

then choose the My Products download software login link

put in your valid grant ( dont forget the -NAI on the end) and submit

depending on what products you have you will now have some lind of link "view avialable downloads"

look in endpoint security section choose virusscan enterprise

agree to terms and conditions

choose patches tab

choose VirusScan Enterprise 8.5i Patch 8

it will download, then unzip it and install as an admin user

if you are missing some tabs somewhere try changing the browser you are using, works for me under FF3.6 and ie8

stuartg
Level 7
Report Inappropriate Content
Message 8 of 18

Re: McAfee OAS: Disabled problem

I'm not sure Patch 8 will solve it. I would try the following:

Disable Access Protection: (VirusScan Console, Access Protection, Stop)

Stop the McAfee Agent, Start>Run>services.msc

Stop "McAfee Common Framework"

If it won't stop then access protection has turned itself back on so go and stop that again, then stop common framework.

Then:

  1. Click Start, Run, type regedit and click OK.
  2. Select the following registry key:

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\mfeapfk]
  3. In the right pane, double-click ImagePath (REG_SZ) and change the Value data from system32\drivers\*.sys to c:\windows\system32\drivers\*.sys
  4. Repeat this for all McAfee services with incomplete ImagePath (REG_SZ) settings.

    These services are all named using the same format:

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\mfexxxx]

    Where xxxx is the name for the relevant service.
  5. Close the registry editor.

All the services that start with MFE and have imagepath as system32\**** need changing

tonyb99
Level 13
Report Inappropriate Content
Message 9 of 18

Re: McAfee OAS: Disabled problem

Thats all very well stuart but he SHOULD be on the latest patch v8, VSE patch 0 is abysmal and I would not wish it on anyone.

Once he has updated we can see if the issue persists and if its related to the filter drivers.

Re: McAfee OAS: Disabled problem

Don't get me wrong, I agree with you that he should be on patch 8, that isn't in question, but I have had this issue and patching isn't always a cure. You just have a more up to date version on 8.5 that still doesn't work.

Try patching, if it still doesn't work, try my solution.

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community