cancel
Showing results for 
Search instead for 
Did you mean: 

McAfee Framework service is MISSING....does not get installed when re-installing

Jump to solution

Hello everyone,

I have a weird situation where i cannot find mcafee framework services from the services.msc

When i re-install both agent and virus scan, the framework service is not installed.

Any help on this?

1 Solution

Accepted Solutions
McAfee Employee hem
McAfee Employee
Report Inappropriate Content
Message 7 of 8

Re: McAfee Framework service is MISSING....does not get installed when re-installing

Jump to solution

I was under impression that VSE was standalone.


Framepkg_upd.exe is standalone agent.

Please uninstall this agent using same switch and either push from ePO or create framepkg.exe and install locally.

on 20/4/11 9:44:22 PM IST
Was my reply helpful?

If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?
7 Replies
McAfee Employee hem
McAfee Employee
Report Inappropriate Content
Message 2 of 8

Re: McAfee Framework service is MISSING....does not get installed when re-installing

Jump to solution

Is installation of VSE succesful? Do you see files in the Common framework folder (\Program files\McAfee\Common framework)?

Do you see registry entries of Agent? Is VSE default package or MID?

Agent installation was succesful or not can be verified in FrmInst.log file Under Temp directory.

Was my reply helpful?

If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

Re: McAfee Framework service is MISSING....does not get installed when re-installing

Jump to solution

Yes the virus scan installation is successful.

Yes,there are files in the common framework folder

I would verify registry entries

the virus scan is the default install package not MID

Agent install was succesful

McAfee Employee hem
McAfee Employee
Report Inappropriate Content
Message 4 of 8

Re: McAfee Framework service is MISSING....does not get installed when re-installing

Jump to solution

Thanks.

Is VSE standalone or ePO managed?

What happens when you uninstall the agent (FrmInst.exe /forceuninstall) then install Framepkg_upd.exe. Is it listed in Services?

Was my reply helpful?

If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

Re: McAfee Framework service is MISSING....does not get installed when re-installing

Jump to solution

The VSE is managed.

The property of the server is recorded on the server as at the 14th april.

I would try your suggestion and revert back to you.

Re: McAfee Framework service is MISSING....does not get installed when re-installing

Jump to solution

HEM,

Great. that worked. I uninstalled using the parameter you gave me. After the unistall i installed the framepkg_upd.exe, and the framework service got reinstalled.

However, I want to believe i have just put the server in an unmanaged mode.

Do i have to re-install the agent and with what switch? Or would it communcate with the server?

McAfee Employee hem
McAfee Employee
Report Inappropriate Content
Message 7 of 8

Re: McAfee Framework service is MISSING....does not get installed when re-installing

Jump to solution

I was under impression that VSE was standalone.


Framepkg_upd.exe is standalone agent.

Please uninstall this agent using same switch and either push from ePO or create framepkg.exe and install locally.

on 20/4/11 9:44:22 PM IST
Was my reply helpful?

If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?
Highlighted

Re: McAfee Framework service is MISSING....does not get installed when re-installing

Jump to solution

The Virus scan is managed.

However, what I noticed after following your previous procedure, was that the McAfee framework service was created.

So all I had to was just install the frame package from the ePO and it now communicates and updates from the ePO server.

Thanks, you are the man....

How do i give you the credit for this?

More McAfee Tools to Help You
  • How-to: Endpoint Removal Tool
  • Support: Endpoint Security
  • Visit: Business Service Portal
  • More: Search Knowledge Articles
  • ePolicy Orchestrator Support
  • The McAfee ePO Support Center Plug-in is now available in the Software Manager. Follow the instructions in the Product Guide for more.