cancel
Showing results for 
Search instead for 
Did you mean: 

Install VSEL on RHEL on silent mode results in frozen installation.

Jump to solution

I am trying to install VSEL silently so that it can be done via a script.

I am running VSEL 2.0.3 on a:

Red Hat Enterprise Linux Server release 7.3 (Maipo) | x86_64

I follow the instructions on pages 5-6 here:https://kc.mcafee.com/resources/sites/MCAFEE/content/live/PRODUCT_DOCUMENTATION/26000/PD26579/en_US/...

 


I run 

    echo """ SILENT_ACCEPTED_EULA=”yes”
    SILENT_INSTALLDIR=”/opt/NAI/LinuxShield”
    SILENT_RUNTIMEDIR=”/var/opt/NAI/LinuxShield”
    SILENT_ADMIN=”admin@example.com”
    SILENT_HTTPHOST=”0.0.0.0”
    SILENT_HTTPPORT=”55443”
    SILENT_MONITORPORT=”65443”
    SILENT_SMTPHOST=”0.0.0.0”
    SILENT_SMTPPORT=”25”
    SILENT_NAILS_USER=”nails”
    SILENT_NAILS_GROUP=”nailsgroup”
    SILENT_CREATE_USER=”yes”
    SILENT_CREATE_GROUP=”yes”
    SILENT_RUN_WITH_MONITOR=”yes”
    SILENT_QUARANTINEDIR=”/quarantine”
    SILENT_START_PROCESSES=”yes” """ > /root/nails.options
    #Run Bash
    bash McAfeeVSEForLinux-2.0.3.29216-installer

 Then the machine just sits forever after printing: 

 

bash McAfeeVSEForLinux-2.0.3.29216-installer

McAfeeVSEForLinux silent install -- options follow from /root/nails.options:
 SILENT_ACCEPTED_EULA=”yes”
    SILENT_INSTALLDIR=”/opt/NAI/LinuxShield”
    SILENT_RUNTIMEDIR=”/var/opt/NAI/LinuxShield”
    SILENT_ADMIN=”admin@example.com”
    SILENT_HTTPHOST=”0.0.0.0”
    SILENT_HTTPPORT=”55443”
    SILENT_MONITORPORT=”65443”
    SILENT_SMTPHOST=”0.0.0.0”
    SILENT_SMTPPORT=”25”
    SILENT_NAILS_USER=”nails”
    SILENT_NAILS_GROUP=”nailsgroup”
    SILENT_CREATE_USER=”yes”
    SILENT_CREATE_GROUP=”yes”
    SILENT_RUN_WITH_MONITOR=”yes”
    SILENT_QUARANTINEDIR=”/quarantine”
    SILENT_START_PROCESSES=”yes” 

 

Labels (2)
1 Solution

Accepted Solutions
Highlighted

Re: Install VSEL on RHEL on silent mode results in frozen installation.

Jump to solution
I found a solution:

There was some white space in my configuration file.
There was 4 spaces in front of every line.
This causes the install to hang indefinitely with no error code.

View solution in original post

1 Reply
Highlighted

Re: Install VSEL on RHEL on silent mode results in frozen installation.

Jump to solution
I found a solution:

There was some white space in my configuration file.
There was 4 spaces in front of every line.
This causes the install to hang indefinitely with no error code.

View solution in original post

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community