cancel
Showing results for 
Search instead for 
Did you mean: 

[Help] Unable to update!! Unable to find a valid repository

I recently downloaded and installed VirusScan Enterprise through my school system on a new office desktop. But it couldn't update for what ever reason.

It said "Unable to find a valid repository"

I did some online research, and still couldn't figure out what's the problem.

I posted log files. an hope anyone here can help me out.

The Updatelog shows

6/25/2012          11:26:23 AM Desktop-168\Desktop168          Starting task: AutoUpdate Daily

6/25/2012          11:26:44 AM Desktop-168\Desktop168          Unable to find a valid repository.

6/25/2012          11:26:44 AM Desktop-168\Desktop168          Update process failed.

6/25/2012          11:44:32 AM Desktop-168\Desktop168          Starting task: AutoUpdate Startup

6/25/2012          11:44:53 AM Desktop-168\Desktop168          Unable to find a valid repository.

6/25/2012          11:44:53 AM Desktop-168\Desktop168          Update process failed.

And the McScript.log is like that:

2012-06-25 11:44:32.827          I          #4252          ScrptMain          START [C:\Program Files (x86)\McAfee\Common Framework\McScript_InUse.exe -script C:\ProgramData\McAfee\Common Framework\UpdateMain.McS -id 27266 -localeid 0409 -parent FRAMEWORK -logfile C:\ProgramData\McAfee\Common Framework\DB\McScript -initiator 0 -ipcid \\.\pipe\upda01824 -installdir C:\Program Files (x86)\McAfee\Common Framework]

2012-06-25 11:44:32.827          I          #4252          ScrptLpc          Saving hash to registry

2012-06-25 11:44:32.827          I          #4200          SutDnWtch          Successfully set up shutdown watch

2012-06-25 11:44:32.837          I          #4252          MueEep          Initializing MUE EEP with IPC ID = \\.\pipe\upda01824 Script ID = 27266

2012-06-25 11:44:32.837          I          #4252          ipcchannel          Connecting to IPC server

2012-06-25 11:44:32.867          I          #4252          persite          Cache file location = C:\ProgramData\McAfee\Common Framework\sitecache.bin

2012-06-25 11:44:32.867          I          #4252          persite          Cabundle file location = C:\ProgramData\McAfee\Common Framework\cabundle.cer

2012-06-25 11:44:32.869          E          #4252          persite          Error trace:

2012-06-25 11:44:32.869          E          #4252          Thread           [Main thread]->

2012-06-25 11:44:32.869          E          #4252          SessMgr           [initialize]->

2012-06-25 11:44:32.869          E          #4252          creposi           [open CRepository]->

2012-06-25 11:44:32.869          E          #4252          persite           [source site list,C:\ProgramData\McAfee\Common Framework\SiteList.xml]->

2012-06-25 11:44:32.869          E          #4252          persite            get IP address failed

2012-06-25 11:44:32.873          I          #4252          creposi          Checking for a valid license.

2012-06-25 11:44:32.873          I          #4252          creposi          License key is not available. Continue in the eval mode.

2012-06-25 11:44:32.874          I          #4252          naInetLic          License Communications Session initialized

2012-06-25 11:44:32.874          I          #4252          naInet          Trying to find an usable proxy using IE settings

2012-06-25 11:44:39.814          I          #4252          naInet          IE: No usable proxy found

2012-06-25 11:44:39.880          I          #4252          naInetLic          License Communications Session closed

2012-06-25 11:44:39.880          E          #4252          creposi          Error trace:

2012-06-25 11:44:39.880          E          #4252          Thread           [Main thread]->

2012-06-25 11:44:39.880          E          #4252          SessMgr           [initializeScript]->

2012-06-25 11:44:39.880          E          #4252          creposi           [setNextRepositoryToUse]->

2012-06-25 11:44:39.880          E          #4252          creposi           [Candidate NAIHttp: testing]->

2012-06-25 11:44:39.880          E          #4252          creposi            Download is allowed from the McAfee repositories but error condition found. Error code:-2. Error message:

2012-06-25 11:44:39.880          I          #4252          naInet          HTTP Session initialized

2012-06-25 11:44:39.881          I          #4252          imsite                    Download to: C:\Windows\TEMP\SiteStat.xml

2012-06-25 11:44:39.881          I          #4252          imsite                    Download from: (NAIHttp) SiteStat.xml

2012-06-25 11:44:39.881          I          #4252          naInet          Trying to find an usable proxy using IE settings

2012-06-25 11:44:42.234          I          #4252          naInet          IE: No usable proxy found

2012-06-25 11:44:42.423          I          #4252          naInet          Open URL: http://update.nai.com:80/products/commonupdater/SiteStat.xml

2012-06-25 11:44:42.423          I          #4252          naInet          Trying to find an usable proxy using IE settings

2012-06-25 11:44:44.780          I          #4252          naInet          IE: No usable proxy found

2012-06-25 11:44:44.862          E          #4252          imsite          Error trace:

2012-06-25 11:44:44.863          E          #4252          Thread           [Main thread]->

2012-06-25 11:44:44.863          E          #4252          SessMgr           [initializeScript]->

2012-06-25 11:44:44.863          E          #4252          creposi           [setNextRepositoryToUse]->

2012-06-25 11:44:44.863          E          #4252          creposi           [Candidate NAIHttp: testing]->

2012-06-25 11:44:44.863          E          #4252          creposi           [downloadFile,SiteStat.xml,C:\Windows\TEMP]->

2012-06-25 11:44:44.863          E          #4252          imsite           [downloadFile,SiteStat.xml,,C:\Windows\TEMP,1]->

2012-06-25 11:44:44.863          E          #4252          imsite            NaInet library returned code == -10

2012-06-25 11:44:44.863          E          #4252          imsite          Error trace:

2012-06-25 11:44:44.863          E          #4252          Thread           [Main thread]->

2012-06-25 11:44:44.863          E          #4252          SessMgr           [initializeScript]->

2012-06-25 11:44:44.863          E          #4252          creposi           [setNextRepositoryToUse]->

2012-06-25 11:44:44.863          E          #4252          creposi           [Candidate NAIHttp: testing]->

2012-06-25 11:44:44.863          E          #4252          creposi           [downloadFile,SiteStat.xml,C:\Windows\TEMP]->

2012-06-25 11:44:44.863          E          #4252          imsite           [downloadFile,SiteStat.xml,,C:\Windows\TEMP,1]->

2012-06-25 11:44:44.863          E          #4252          imsite            NaInet library returned code == -10

2012-06-25 11:44:44.863          E          #4252          imsite          Error trace:

2012-06-25 11:44:44.863          E          #4252          Thread           [Main thread]->

2012-06-25 11:44:44.863          E          #4252          SessMgr           [initializeScript]->

2012-06-25 11:44:44.864          E          #4252          creposi           [setNextRepositoryToUse]->

2012-06-25 11:44:44.864          E          #4252          creposi           [Candidate NAIHttp: testing]->

2012-06-25 11:44:44.864          E          #4252          creposi           [downloadFile,SiteStat.xml,C:\Windows\TEMP]->

2012-06-25 11:44:44.864          E          #4252          imsite           [downloadFile,SiteStat.xml,,C:\Windows\TEMP,1]->

2012-06-25 11:44:44.864          E          #4252          imsite            The naInet library returned an error. [Parent error: NaInet library returned code == -10]

2012-06-25 11:44:44.864          I          #4252          creposi          Checking for a valid license.

2012-06-25 11:44:44.864          I          #4252          creposi          License key is not available. Continue in the eval mode.

2012-06-25 11:44:44.864          I          #4252          naInetLic          License Communications Session initialized

2012-06-25 11:44:44.864          I          #4252          naInet          Trying to find an usable proxy using IE settings

2012-06-25 11:44:47.225          I          #4252          naInet          IE: No usable proxy found

2012-06-25 11:44:47.400          I          #4252          naInetLic          License Communications Session closed

2012-06-25 11:44:47.400          E          #4252          creposi          Error trace:

2012-06-25 11:44:47.400          E          #4252          Thread           [Main thread]->

2012-06-25 11:44:47.400          E          #4252          SessMgr           [initializeScript]->

2012-06-25 11:44:47.400          E          #4252          creposi           [setNextRepositoryToUse]->

2012-06-25 11:44:47.400          E          #4252          creposi           [Candidate NAIFtp: testing]->

2012-06-25 11:44:47.400          E          #4252          creposi            Download is allowed from the McAfee repositories but error condition found. Error code:-2. Error message:

2012-06-25 11:44:47.400          I          #4252          naInet          FTP Session initialized

2012-06-25 11:44:47.400          I          #4252          imsite                    Download to: C:\Windows\TEMP\SiteStat.xml

2012-06-25 11:44:47.401          I          #4252          imsite                    Download from: (NAIFtp) SiteStat.xml

2012-06-25 11:44:47.401          I          #4252          naInet          Trying to find an usable proxy using IE settings

2012-06-25 11:44:49.757          I          #4252          naInet          IE: No usable proxy found

2012-06-25 11:44:51.079          I          #4252          NaInet          FTP Downloading file: SiteStat.xml from FTP Server: ftp.nai.com

2012-06-25 11:44:51.079          I          #4252          naInet          Open URL: ftp://ftp.nai.com:21/CommonUpdater/SiteStat.xml

2012-06-25 11:44:51.080          I          #4252          naInet          Trying to find an usable proxy using IE settings

2012-06-25 11:44:53.446          I          #4252          naInet          IE: No usable proxy found

2012-06-25 11:44:53.668          E          #4252          imsite          Error trace:

2012-06-25 11:44:53.668          E          #4252          Thread           [Main thread]->

2012-06-25 11:44:53.669          E          #4252          SessMgr           [initializeScript]->

2012-06-25 11:44:53.669          E          #4252          creposi           [setNextRepositoryToUse]->

2012-06-25 11:44:53.669          E          #4252          creposi           [Candidate NAIFtp: testing]->

2012-06-25 11:44:53.669          E          #4252          creposi           [downloadFile,SiteStat.xml,C:\Windows\TEMP]->

2012-06-25 11:44:53.669          E          #4252          imsite           [downloadFile,SiteStat.xml,,C:\Windows\TEMP,1]->

2012-06-25 11:44:53.669          E          #4252          imsite            NaInet library returned code == -10

2012-06-25 11:44:53.669          E          #4252          imsite          Error trace:

2012-06-25 11:44:53.669          E          #4252          Thread           [Main thread]->

2012-06-25 11:44:53.669          E          #4252          SessMgr           [initializeScript]->

2012-06-25 11:44:53.669          E          #4252          creposi           [setNextRepositoryToUse]->

2012-06-25 11:44:53.669          E          #4252          creposi           [Candidate NAIFtp: testing]->

2012-06-25 11:44:53.669          E          #4252          creposi           [downloadFile,SiteStat.xml,C:\Windows\TEMP]->

2012-06-25 11:44:53.669          E          #4252          imsite           [downloadFile,SiteStat.xml,,C:\Windows\TEMP,1]->

2012-06-25 11:44:53.669          E          #4252          imsite            NaInet library returned code == -10

2012-06-25 11:44:53.669          E          #4252          imsite          Error trace:

2012-06-25 11:44:53.669          E          #4252          Thread           [Main thread]->

2012-06-25 11:44:53.669          E          #4252          SessMgr           [initializeScript]->

2012-06-25 11:44:53.669          E          #4252          creposi           [setNextRepositoryToUse]->

2012-06-25 11:44:53.669          E          #4252          creposi           [Candidate NAIFtp: testing]->

2012-06-25 11:44:53.669          E          #4252          creposi           [downloadFile,SiteStat.xml,C:\Windows\TEMP]->

2012-06-25 11:44:53.670          E          #4252          imsite           [downloadFile,SiteStat.xml,,C:\Windows\TEMP,1]->

2012-06-25 11:44:53.670          E          #4252          imsite            The naInet library returned an error. [Parent error: NaInet library returned code == -10]

2012-06-25 11:44:53.675          I          #4252          ScrptMain          McAfee Update Engine is exiting with return code: 1

2012-06-25 11:44:53.675          I          #4252          naInet          HTTP Session closed

2012-06-25 11:44:53.675          I          #4252          naInet          FTP Session closed

2012-06-25 11:44:53.675          I          #4252          SessMgr          Unable to find any valid repository

2012-06-25 11:44:53.675          I          #4252          MueEep          Invoking events withEventId " 0" Severity " 0" Productid " EPOAGENT3000" Locale " 0409" UpdateType " N/A" UpdateError " 26" New Version " N/A" Date Time " N/A" Script Id" 27266"

2012-06-25 11:44:53.687          I          #4252          MueEep          Deinitializing entry execution point

2012-06-25 11:44:53.687          I          #4252          MueEep          Deinitializing container

2012-06-25 11:44:53.687          I          #4252          ipcchannel          Closing IPC connection

2012-06-25 11:44:53.687          I          #4252          MueEep          Deleting container

2012-06-25 11:44:53.687          I          #4252          Thread          Exit program

7 Replies
Highlighted

Re: [Help] Unable to update!! Unable to find a valid repository

Looks like its having issues finding a valid Proxy from Internet Explorer. Do you have a Proxy defined in IE?

Re: [Help] Unable to update!! Unable to find a valid repository

Hi Strongy,

Thanks for replying. I think you are right about the problem. I just don't know how to fix it.

I checked Internet Properties --> Local Area Network (LAN) setting. There is no Proxy defined anywhere. But in case I am wrong, I paste the screen snapshot here.

LAN settings.jpg

Tristan
Level 15
Report Inappropriate Content
Message 4 of 8

Re: [Help] Unable to update!! Unable to find a valid repository

What happens when you try and visit http://update.nai.com:80/products/commonupdater/SiteStat.xml or ftp://ftp.nai.com:21/CommonUpdater/SiteStat.xml from the browser on this computer?

Also your install is in Evaluation mode. When you mentioned your school system, do you have an ePO server on the network or you mean you just downloaded a trial version from the McAfee website.

Message was edited by: Tristan on 26/06/12 16:11:52 IST

Re: [Help] Unable to update!! Unable to find a valid repository

when I clicked the two links, they all showed like that:

This XML file does not appear to have any style information associated with it. The document tree is shown below.

<SiteStatus Status="Enabled" CatalogVersion="20120625080155"> </SiteStatus>

Idon't understand what you mean by "your install is in Evaluation mode". Do you mean McAfee or operatiing system?

Also about the version of McAfee, it is a school-customized version of McAfee VirusScan. "The University offers a licensed copy of McAfee VirusScan for employee-, student-, and University-owned computers. If you are unsure of your eligibility to download the UD-licensed version, click Contact Us at the bottom of this page." according to school website.

I never use ePO server, or I didn't know I used it.

Tristan
Level 15
Report Inappropriate Content
Message 6 of 8

Re: [Help] Unable to update!! Unable to find a valid repository

2012-06-25 11:44:32.873          I          #4252          creposi          Checking for a valid license.

2012-06-25 11:44:32.873          I          #4252          creposi          License key is not available. Continue in the eval mode.

2012-06-25 11:44:32.874          I          #4252          naInetLic          License Communications Session initialized.

McAfee is in eval mode

Tristan
Level 15
Report Inappropriate Content
Message 7 of 8

Re: [Help] Unable to update!! Unable to find a valid repository

http://hydra.geht.net/tino/howto/windows/win7/proxycfg/

Also try these instructions for checking your system proxy settings.

Possibly a

netsh winhttp reset proxy

will clear any rouge proxy settings

Re: [Help] Unable to update!! Unable to find a valid repository

Thank you, Tristan.

I followed the instruction to redo all the proxy. It's all direct access and no proxy settings.

But the problem is still there.

You pointed out a really good problem, the license key is not available. I still don't know why and I'm contacting School IT and to see anything went wrong with license. Meanwhile the other computers I have is also using this version VSE. They all run fine.

Any more thought?

More McAfee Tools to Help You
  • How-to: Endpoint Removal Tool
  • Support: Endpoint Security
  • Visit: Business Service Portal
  • More: Search Knowledge Articles
  • ePolicy Orchestrator Support
  • The McAfee ePO Support Center Plug-in is now available in the Software Manager. Follow the instructions in the Product Guide for more.