cancel
Showing results for 
Search instead for 
Did you mean: 
eddzzz
Level 7
Report Inappropriate Content
Message 1 of 6

Error 80040154 after update to 8.7.0i

I updated my McAfee to VirusScan Enterprise 8.7.0i Patch 4 using the command "SetupVSE.Exe /quiet". (I updated to VirusScan Enterprise 8.5.0i Patch 6 )

But after a reboot I now get the error "Failed to initialize Common Updater subsystem. ... McAfee Common Framework returned error 80040154 @ 1"

What went wrong?

How can I fix this?

And how should I have updated my system? (Cause I need to do a lot of other ones as well.)

Thanks!

5 Replies
wwarren
Level 15
Report Inappropriate Content
Message 2 of 6

Re: Error 80040154 after update to 8.7.0i

Searching our knowledge base for that error finds this article:

https://kc.mcafee.com/corporate/index?page=content&id=KB57899

William W. Warren | S.I.R.R. | Customer Success Group | McAfee
eddzzz
Level 7
Report Inappropriate Content
Message 3 of 6

Re: Error 80040154 after update to 8.7.0i

Yes, I found that knowledge base item. Problem is there is no SecureFrameworkFactory.dll.

I tested it on another machine, and it appears that the update removes the Common Framework folder completely. Why is that?

How can I reïnstall the Common Framework?

And how can I prevent it from removing it?

eddzzz
Level 7
Report Inappropriate Content
Message 4 of 6

Re: Error 80040154 after update to 8.7.0i

Nobody knows a solution to this problem?

Re: Error 80040154 after update to 8.7.0i

For the what went wrong more data would be needed, best to open a SR for it.

Maybe you can fix it either by using framepkg_upd.exe when updating Agent or if needed to use the same version to overwrite the current one with /force (assuming this is really an agent issue)

Re: Error 80040154 after update to 8.7.0i

thanks Mr.dyilmaz its worked well.....