cancel
Showing results for 
Search instead for 
Did you mean: 

Error 1920 - during Virusscan Enteprise 8.7i patch4 installation

Greetings!

Hear me out.

A user had a problem with virus scan (see the strange attachment below, please don’t laugh, this is what randomly appears on user’s computer windows tray).

Ok, we decided to solve this problem by uninstalling the MacAfee agent 4.5 and virus scan 8.7 on the computer.

I did uninstall MacAfee agent by running command prompt on client computer:

* c:\program files\mcaffee\common files\frminst.exe /remove=agent

* c:\program files\mcaffee\common files\frminst.exe /forceuninstall

I have uninstalled Virusscan Enterprise in add remove programs.

I have opened regedit:

HKLM/SOFTWARE and deleted mcafee map and network associates

I have deleted map in explorer C:\program files\mcafee and c:\program files\common files\mcafee

* rebooted the pc

Ok, installed agent again .... with no problem

Tried installing virusscan by chosing typical installation at the middle of the installation (when starting service), 1920 error appears.

I have googled a lot of pages and noone did came with good results.

-I have followed instructions that I mus re-run the installation and after the message appears, I must open registry in HKLM\system\currentControlSet\services and change path for keys: mfeapfk, mfeavfk, mfebopk by entering full path to c:\windows\.... and cancel the error message of virusscan installation and try to reinstall program again, but the same error message appears.

-also google found me solution that I must use vse 8.7 latest patch installation but i am already doing that.

So, please where did i go wrong or in other words, how can I solve this problem?

with best regards,

5 Replies
Tristan
Level 15
Report Inappropriate Content
Message 2 of 6

Re: Error 1920 - during Virusscan Enteprise 8.7i patch4 installation

I've used this Microsoft utility in the past to clean up Corrupt Mcafee installs

http://en.wikipedia.org/wiki/Windows_Installer_CleanUp_Utility

I would try the following steps

1. Uninstall VSE via control panel or above utility

2. delete all McAfee registry entries

3. delete all Mcafee references in 'c:\Program Files\mcafee', 'c:\program files\common files' &  'c:\documents and settings\all users\application data'

4. check that the services are being removed correctly in HKLM\system\currentControlSet\services  (and delete in safe mode if nessesary)

Re: Error 1920 - during Virusscan Enteprise 8.7i patch4 installation

Greetings Tristan!

Thank you for your reply.

I have deleted:

'c:\Program Files\mcafee', 'c:\program files\common files' &  'c:\documents and settings\all users\application data'

I have gone through registry and deleted anything found by mcafee and virusscan, rebooted the comp, started the reinstallation, same error

For heaven sake will I really need to reformat this pc?

Tristan
Level 15
Report Inappropriate Content
Message 4 of 6

Re: Error 1920 - during Virusscan Enteprise 8.7i patch4 installation

Right.....The attached image gives some insight into the issue.

Are you as part of your install procedure install the agent then VSE?

Have you tried uninstalling everything then installing VSE first?

Basically your problem is with the agent. As part of the install process VSE installs/updates/stops/restarts the framework agent service and this is where it's falling over.

Searching google for "Error 1920 mcafee agent" brings up a few leads like below.

https://kc.mcafee.com/corporate/index?page=content&id=KB59472

https://community.mcafee.com/message/21706

Do you do anything 'exotic' with the mapping of temporary folders of user profiles within your network or have Dynamic disks set up on the computer?

Re: Error 1920 - during Virusscan Enteprise 8.7i patch4 installation

Thank you for your time.

We have tried installing avg free just because we did not want the client to be unprotected until the program is solved.

The avg installation also did not work. Then we have installed eset nod which worked ok. The client will have a NOD antivirus for awhile, cause he will receive a new machine with win 7 in near future soo we will not to try to solve the problem anymore. But that temp issue seems logical.

Thank you for you time and help.

Re: Error 1920 - during Virusscan Enteprise 8.7i patch4 installation

I've had a simalar issue trying ot install VSE8.7i.  The problem was spyware.  I ran MalwareBytes and it found a bunch of stuff, cleaned the machine and the VSE install worked fine after that.

More McAfee Tools to Help You
  • Subscription Service Notification (SNS)
  • How-to: Endpoint Removal Tool
  • Support: Endpoint Security
  • eSupport: Policy Orchestrator
  • Community Help Hub

      New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

    • Find Forum FAQs
    • Learn How to Earn Badges
    • Ask for Help
    Go to Community Help

    Join the Community

      Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

    • Get helpful solutions from McAfee experts.
    • Stay connected to product conversations that matter to you.
    • Participate in product groups led by McAfee employees.
    Join the Community
    Join the Community