cancel
Showing results for 
Search instead for 
Did you mean: 

Can't install McAfee agent | Error 1904 ..\ma_compat_agent.dll failed to register

Hello Guy!

I don't know why i can't install McAfee agent.The error massage is Error 1904 Module C:\Program Files\McAfee\Agent\ma_compat_agent.dll failed to register. HRESULT -2147024769. Contact your support personnel. Please reply me if you know how to solve this issue.

Thank you.

7 Replies
kmc
Level 12
Report Inappropriate Content
Message 2 of 8

Re: Can't install McAfee agent | Error 1904 ..\ma_compat_agent.dll failed to register

Possibly associated software packages are mismatch,

you can try ignoring the alert and try manually register the specific dll by using the below command

regsvr32 C:\Program Files\McAfee\Agent\ma_compat_agent.dll

Re: Can't install McAfee agent | Error 1904 ..\ma_compat_agent.dll failed to register

I'll try to do this.

Thank you.

ISmith
Level 9
Report Inappropriate Content
Message 4 of 8

Re: Can't install McAfee agent | Error 1904 ..\ma_compat_agent.dll failed to register

Did you ever get this resolved?

Re: Can't install McAfee agent | Error 1904 ..\ma_compat_agent.dll failed to register

Hi, i tried to ignore erros on instalation but at some point Agent gives a msg that cannot continue and rollback itself.

ISmith
Level 9
Report Inappropriate Content
Message 6 of 8

Re: Can't install McAfee agent | Error 1904 ..\ma_compat_agent.dll failed to register

Good morning.

I have a case open with McAfee support for this issue. What I am told is that there is a bug (or two) and that there will be a new McAfee agent release in the future.

Re: Can't install McAfee agent | Error 1904 ..\ma_compat_agent.dll failed to register

Hi, even on Mcafee Agent 5.6.1?

ISmith
Level 9
Report Inappropriate Content
Message 8 of 8

Re: Can't install McAfee agent | Error 1904 ..\ma_compat_agent.dll failed to register

Yes. I tested the various 5.6.0 up to 5.6.0.940 and 5.6.1.157.

One work around that improved the chances of success was to run the McAfee Endpoint Product Removal tool and remove ALL products (even if there were none ever installed). Then reboot and the agent install *may* work. This workaround was not always successful.

I believe agent 5.5.1 does not have this bug, so if you can use that it may also be a work-around.

 

More McAfee Tools to Help You
  • Subscription Service Notification (SNS)
  • How-to: Endpoint Removal Tool
  • Support: Endpoint Security
  • eSupport: Policy Orchestrator