cancel
Showing results for 
Search instead for 
Did you mean: 

Access Protection is not shown in VSE Console

Hi,

we have VSE 8.8 P5 (and P6 for testing purpose) and wanted to activate the Access Protection like explained in the Thread Advisory for Locky and W97M.

Now we have the problem that the Access Protection (Zugriffschutz) is not shown in the VSE console:vse_console.png

The policy Access Protection is enabled:

epo_policy.png

Has anybody a hint for that problem?

Same behaviour with P5 and P6.

We didn´t find anything.

7 Replies
wwarren
Level 15
Report Inappropriate Content
Message 2 of 8

Re: Access Protection is not shown in VSE Console

The content of the Console is determine by console plugins that get loaded when you open the Console.

These console plugins are identifiable from their file names, found in the VSE install folder, that look like *cpl.dll

e.g.

BBcpl.dll (behavior blocking)

coptcpl.dll (console options)

EmCfgcpl.dll (Email configuration)

..etc.

Access Protection is controlled by the behavior blocking cpl plugin. Perhaps it is not loading. Perhaps it is not even there. Clearly something is amiss.

William W. Warren | S.I.R.R. | Customer Success Group | McAfee

Re: Access Protection is not shown in VSE Console

I checked the install Folder and found the bbcpl.dll:

bbcpl.png

Can i check if there is a Problem with the .dll ("error while loading" entry in a log?) or maybe can i load it manually?

wwarren
Level 15
Report Inappropriate Content
Message 4 of 8

Re: Access Protection is not shown in VSE Console

There's no such log.

But, you can try to learn what happens when the McConsol.exe loads the DLL by using Process Monitor. Run the tool, then launch the Console.

The captured entries may suggest a problem - you could filter the log to show "Path" <ends with> "bbcpl.dll"... but if there are no obvious errors like ACCESS_DENIED, and the DLL is being loaded, then it sounds like a programmatic reasoning for not displaying the feature. That would be very odd, and would cast suspicion upon the health of the installation in general.

If you do see ACCESS_DENIED as the Result when accessing the file, the challenge will be to discover why.

William W. Warren | S.I.R.R. | Customer Success Group | McAfee

Re: Access Protection is not shown in VSE Console

I´ll check it with ProcMon and post as soon as i get results.

In the meantime we checked our Installation packages.

It was designed with the MID and maybe it is possible that during the design the Access protection was not checked for Installation.

Maybe we have to install the Feature afterwards?

Is there a possibility for that?

Re: Access Protection is not shown in VSE Console

I have the results of the ProcMon Analyse.

There are many Success and some File Locked with only Readers Messages.

Nothing special as i would say.

I tested Patch 7 too.

Problem stays the same.

I also make a call.

Any other ideas?

wwarren
Level 15
Report Inappropriate Content
Message 7 of 8

Re: Access Protection is not shown in VSE Console


It was designed with the MID and maybe it is possible that during the design the Access protection was not checked for Installation.


Maybe we have to install the Feature afterwards?


Is there a possibility for that?


Yes. That's possible.

If you think the procmon data tells a benign story, this is a the most probable reason.

Otherwise, I suggest contacting Support and sharing your findings so far.

William W. Warren | S.I.R.R. | Customer Success Group | McAfee
masten
Level 9
Report Inappropriate Content
Message 8 of 8

Re: Access Protection is not shown in VSE Console

Check this KB out:

https://kc.mcafee.com/corporate/index?page=content&id=KB84913

Use Workaround 3 which most prabably will do the trick for you.