cancel
Showing results for 
Search instead for 
Did you mean: 

8.5.0i Various Errors, McShield paused.

Hi,

I'm getting the following errors and the McShield service keeps staying in a paused state.

Event ID 5022:

MCSCAN32 Engine Initialisation failed. Engine returned error : 8

Event ID: 5004

Could not contact Filter Driver.
Error = 0x2 : The system cannot find the file specified.


Event ID: 7000

The McAfee Inc. service failed to start due to the following error:
The filename, directory name, or volume label syntax is incorrect.


I have removed McAfee Enterprise and the Agent using Add/Remove Programs and frminst/forceuninstall, and then used the mcpr.exe tool to get rid of anything left over.

I have rebooted, used ccleaner and deleted all mcafee files from program files etc. But it just won't work. Everytime I reinstall, Access Protection is automatically disabled, buffer overflow is disabled and so is on-access scanner. This is BEFORE installing the agent.

Does anyone have any ideas on what I can do?

I checked the drivers were all installed and that their path names were fully entered in the registry.


Thanks
3 Replies
Grif
Level 10
Report Inappropriate Content
Message 2 of 4

RE: 8.5.0i Various Errors, McShield paused.

Suggestions.

1. mcpr.exe is for removing RETAIL VERSIONS of McAfee ONLY.. It does nothing for the corporate Enterprise versions of McAfee VirusScan.

2. Please tell us the version of your Enterprise VirusScan program.. In order to completely remove the corporate version, please follow the manual removal instructions in the appropriate link below:

Manual Uninstall of Virus Scan Enterprise 8.0i
http://community.mcafee.com/showpost...02&postcount=2
or
https://kc.mcafee.com/corporate/inde...ent&id=KB58597

Manual Uninstall Of Virus Scan Enterprise 8.5i
http://community.mcafee.com/showpost...05&postcount=2
or
https://kc.mcafee.com/corporate/inde...ent&id=KB50602

How to Manually Uninstall McAfee VirusScan Enterprise 8.7i
http://community.mcafee.com/showpost...68&postcount=5
or
https://kc.mcafee.com/corporate/inde...ent&id=KB59996

3. Since you may have malware on your machine, please run the ESET free scanner at the link below:

ESET Online Scanner - Requires an Internet Connection
____________

Once you're sure the computer is free from ALL previous antivirus programs AND free from all malware, then try reinstalling McAfee again.

Hope this helps.

Grif

RE: 8.5.0i Various Errors, McShield paused.

Hi Grif,

Thanks for that. It is version 8.5.0i I am using.

I did the manual uninstall as instructed, and also the malware scan which came up clean.

Still not working.

Two more things which I forgot to mention... The Framework service does not install during setup, I can install the framework service using the downloaded package from ePO and that will then run okay.

The mcshield service will not restart from paused, giving this error every time:
Could not stop the McAfee McShield service on Local Computer

Error 5: Access is Denied


The service is running on local system account.

Any more ideas....?

Thanks

Problem found!

This machine was built by someone else.... and.. the TEMP drive was set to y:\temp. - The Y drive no longer exists so that was what was causing the problem! I switched the temp to the C drive and the install worked fine.

:eek:
More McAfee Tools to Help You
  • Subscription Service Notification (SNS)
  • How-to: Endpoint Removal Tool
  • Support: Endpoint Security
  • eSupport: Policy Orchestrator
  • Community Help Hub

      New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

    • Find Forum FAQs
    • Learn How to Earn Badges
    • Ask for Help
    Go to Community Help

    Join the Community

      Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

    • Get helpful solutions from McAfee experts.
    • Stay connected to product conversations that matter to you.
    • Participate in product groups led by McAfee employees.
    Join the Community
    Join the Community