cancel
Showing results for 
Search instead for 
Did you mean: 

SG560 4.0.7 firmware - accessing WebGUI spike cpu cause unit to reboot

We've been having issues with 4.0.7 on an SG560 (secure computing branded unit) where accessing the webgui will bring the unit to it's knees (high cpu spike) and at times eventualy reboot itself! I've tried redoing the config from scratch again and using a different piece of hardware / SG560 (just in case) but the same thing happens. This does not happens if I do not have the WAN pluged in (during config / testing) and active / running.

The interesting thing is if I do not access the webgui the unit work with no issues (that we've noticed) ???

It's config with ADSL WAN, 2 LAN and 1 DMZ with 1 IPsec & GRE VPN connection using self generated SSL certs with static routing, am I making do too much work??

10 Replies
rcamm
Level 13
Report Inappropriate Content
Message 2 of 11

Re: SG560 4.0.7 firmware - accessing WebGUI spike cpu cause unit to reboot

The 560 is memory challenged under version 4.....which is why accessing the web interface will cause the problem, as the cgi scripts will consume about a quarter of the total RAM.

Do you have anything enabled under system -> management such as snmpd or UCC ?

If so, disabling this generally free's up enough RAM to keep it happy.

Hope this helps.

Re: SG560 4.0.7 firmware - accessing WebGUI spike cpu cause unit to reboot

Thanks for the reply Ross.

Yes I do have SNMP on. Does this mean I can't make use of SNMP are there other services I can deactivate instead of SNMP?

Is there a console command I can use to disable SNMP as doing it via webgui will bring it down again

Message was edited by: orionweb on 13/07/10 1:40:09 PM
rcamm
Level 13
Report Inappropriate Content
Message 4 of 11

Re: SG560 4.0.7 firmware - accessing WebGUI spike cpu cause unit to reboot

snmpd takes over 3 Meg RAM, and as such is really the only candidate to disable, as you will notice there are not many other options left.

Disabling this fixes the shortcomings of the RAM limitation for all customers I have advised this to.

Re: SG560 4.0.7 firmware - accessing WebGUI spike cpu cause unit to reboot

I've managed to disable SNMP, now the webgui is much more snapier

Re: SG560 4.0.7 firmware - accessing WebGUI spike cpu cause unit to reboot

Forgot to mention that webgui has been configured to be htttps and on a non standard port.

Is there a way for me to access it via the console to monitor what processes is causing the cpu usage to get a better idea on how to fix this? 'top' doesn't work on the SG560

rcamm
Level 13
Report Inappropriate Content
Message 7 of 11

Re: SG560 4.0.7 firmware - accessing WebGUI spike cpu cause unit to reboot

running

ps

from the command line will show all running processes and the amount of RAM they are consuming.

bigmuzb
Level 7
Report Inappropriate Content
Message 8 of 11

Re: SG560 4.0.7 firmware - accessing WebGUI spike cpu cause unit to reboot

I had this exact issue and a bloke who worked on them in a former life suggested that disabling all graphing would help and since then it has been fine.


FYI

Cheers

Muz

Re: SG560 4.0.7 firmware - accessing WebGUI spike cpu cause unit to reboot

Thanks for the sugestion, any idea how I go about disabling the graphing? I'll take SNMP over the graphing as it will have historical records compare to the short retention on the unit.

Re: SG560 4.0.7 firmware - accessing WebGUI spike cpu cause unit to reboot

Back it up first!

advanced

device config

Then set all the graph.xx to 0 and 'source' to  'none'.

I can't say whether that will solve your problem but it helped me. We don't currently use snmp but turning the graphing off has made it much more reliable,

Cheers

Muz