cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Vindy
Level 8
Report Inappropriate Content
Message 1 of 10

TrueKey stopped working in Chrome on all my PCs (and Mac)

Jump to solution

Hi there,

I've been using TrueKey Premium for a number of years, without issue.

Suddenly it stopped working for me in Chrome, a couple of weeks ago.
I assumed an update to Chrome broke it.
I have tried it on three PCs so far, same on each.
The blue icon no longer shows on password dialogue boxes, but I can click on the TrueKey extensions icon in Chrome and I'm still logged in and can manually view, and copy and paste passwords.

Clicking on a saved website in TrueKey also no longer works.  It takes me to the URL that's saved, but no login occurs.

Chrome is still set to use TrueKey for password management, nothing has changed, it simply stopped working on my machines a couple of weeks ago. All Win 10.

The first I noticed is that it stopped working on my Surface tablet, but then I noticed the following day that it no longer functions on my main workstation, nor my laptop.


I've tried disabling TrueKey and reenabling, I've tried disabling the Chrome setting to allow TrueKey to manage passwords, and reenable it. Doesn't help.


TrueKey is running, I'm signed in, but it never offers passwords for sites, nor does it offer to generate passwords for new signups (such as for this very forum) and the blue icon in the password boxes no longer appears, on at least three separate systems.
Chrome Version 89.0.4389.90 (Official Build) (64-bit)

I keep meaning to try Chrome on my M1 Mac to see if it works.... I'll boot it up and try now before posting this.

 

No, it doesn't work on the Mac, either.

After first boot I logged into TrueKey and tried it, didn't work on

Version 89.0.4389.82 (Official Build) (arm64)

 

Then Chrome updated itself, tried TrueKey again, still doesn't work

Version 89.0.4389.90 (Official Build) (arm64)

 

As with the Windows machines, I am logged in, I can view credentials, copy/paste, etc, but I get no blue icon in password boxes.

You realise how handy something is, when it's gone!

I'd become very reliant on TrueKey to sign me into websites!

Hoping it can be fixed soon.

Thanks.

 

EDIT: My TrueKey extension reports its version number as

version: 4.3.0.9324

This does appear to be the latest version available from the Chrome Web Store

https://chrome.google.com/webstore/detail/true-key-by-mcafee/cpaibbcbodhimfnjnakiidgbpiehfgci

 

1 Solution

Accepted Solutions
Vindy
Level 8
Report Inappropriate Content
Message 9 of 10

Re: TrueKey stopped working in Chrome on all my PCs (and Mac)

Jump to solution

OK, I think I've fixed it myself, now.

I was just thinking.... what do all of these systems have in common that could cause this issue?
I mean, it was even not working on Mac OS, as well as all my separate Windows PC. Can't be cookies, can be.... extensions? I have TrueKey running in Chrome, and Chrome installs the same extensions across all Chrome installs on your Google account.

I was looking at the web interface login screen for one of my internal devices.
All extensions are disabled. AdBlock, Ghostery.... etc. But TrueKey still didn't work (unless I did the aforementioned toggle of the Allow In Incognito Mode which appears to restart TrueKey and then it works until Chrome is restarted)
What if another extension is starting up and messing up TrueKey?

So, I went to my extensions in Chrome. I had 5 or 6 that I haven't used for years. They were disabled, but not removed.
I had thought that when they're disabled, they can't cause any issues.

WRONG.

All of the old extensions that I no longer use have been removed. I can't say which one caused the issue, because I removed a whole lot at once.

I went back to the webinterface page, refresh... TrueKey is alive!

I visited the URL for this forum, TrueKey signed me in!

I closed Chrome. Revisited my web interface. TrueKey worked immediately.

So, one of the disabled extensions was somehow blocking TrueKey.
Changing the Incognito Mode setting seems to have restarted TrueKey and made it work, so perhaps an extension was updated in Chrome, and started after TrueKey, and somehow blocked it, despite the fact it was disabled.

This is the best I can come up with right now.

There's no need to have old, disabled extensions lying around anyway, It's probably a security risk in itself. I'm still surprised that a disabled extension can cause an issue but..... I seem to have found my own solution.
(I had even removed the TrueKey extension and reinstalled, and this didn't help)

Maybe this can help someone else in the future, and even if you're not having issues, consider removing all old/disabled extensions)

Thanks for reading.
Vin.

 

EDIT: Confirmed working on second system.  I have just booted up my Surface tablet (on which I am now typing this).  I allowed Chrome to start, I visited the local web interface  No TrueKey.  I checked installed extensions and noticed that all the extensions I'd removed using my workstation were now removed from Chrome on this machine, so I assume that the extensions started up during Chromes boot and were then removed.  So to test this, I closed Chrome, reopened it, revisited the local webinterface and TrueKey was working as it should.

So it would appear this did indeed fix my issue, even though as I mentioned above, the extensions that I removed were already disabled.  Thanks.

View solution in original post

9 Replies
Magesh
Moderator
Moderator
Report Inappropriate Content
Message 2 of 10

Re: TrueKey stopped working in Chrome on all my PCs (and Mac)

Jump to solution

Hi @Vindy 

Please check if the chrome browser is up to date and also check if the same issue  is observed on firefox and as well as edge browsers..

Kindly remove and re install true key web extension and check the issue status and update  us on the outcome..

Thanks,

Vindy
Level 8
Report Inappropriate Content
Message 3 of 10

Re: TrueKey stopped working in Chrome on all my PCs (and Mac)

Jump to solution

Hi there,

As per my original post, the Chrome versions are up to date on my PCs and Mac.

I don't run Firefox.

I'm currently using the Mac, which doesn't use Edge... and I don't want to use TrueKey with Edge, anyway.

But, here on the Mac I did just remove the TrueKey extension from Chrome, then I force quit Chrome to make sure it was closed, opened it fresh, and reinstalled TrueKey using the link I posted, also in my original post.

 

Phew, that was a bit of a nightmare.  I had real issues signing in, this evening.

At first it just said "that did not work" for my email address, and after a few attempts it did work, but after entering my password it would tell me that it cannot connect to the TrueKey servers. I've had this happen many times through the years, just typical it would happen this evening.  Anyway... after approx 10 attempts it accepted my password and then wanted to 2FA to a trusted device.  No notification appeared on my iPhone, so I loaded the TrueKey app on my phone to see if this would help.  The phone also had issues signing in, but after 3 attempts, it logged in. Still no notification. 

I spent a further 10 minutes trying to sign in on Chrome, and finally got back to the 2FA screen. I tried multiple times, no notification would appear on my phone.  I even went to the TrueKey settings on my phone and confirmed that it's a trusted device, and was last logged in at the current time.  Luckily I also have an iPad listed as a trusted device, and this worked first time. 

I am unable to use email to recover the account, as I had to close down my old email address and start a new one, and I've never found a way to change my email with TrueKey.

 

ANYWAY, after all that, the original issue persists. 

Now that I'm logged in, I can click on the TrueKey extension icon and view all my passwords, however, when attempting to sign into a website, for example, this forum, I do not see the blue TrueKey icons in the password boxes, and I am not signed in. I had to go to the TrueKey extension and copy and paste the password to log into this forum, to type this post.

The issues logging in were frustrating, but I'm more concerned that my main phone didn't work for 2FA, so I'll look into this later and maybe remove it as a trusted device, and then readd it. 

But anyway, the original issue is still there. I saw a post earlier this week from someone having the exact same issue with Brave.  This is what convinced me to make an account to give my own account of the issue, but in Chrome.

I'm not sure what else I can do?  Having completely removed the extension and reinstalled it, and that not solving the issue.... I really hope it works again soon. It's worked fine for years, on all my systems. 

Thanks for the help

Vin.

Vindy
Level 8
Report Inappropriate Content
Message 4 of 10

Re: TrueKey stopped working in Chrome on all my PCs (and Mac)

Jump to solution
Replying to self:

I've just made it work!
Whether it's coincidence and it would've started working on its own, or not, I don't know, but this is what I did.

Because I'd just reinstalled TrueKey fresh, I had to go to the extensions settings in Chrome, and set TrueKey to work in Incognito Mode. Sometimes I like to browse in Incognito Mode to avoid Cookies from certain sites, so it's doubly convenient to have TrueKey running to sign me in, without cookies.
ANYWAY, While I was looking at the "Manage Extensions" settings, I noticed the tickboxes for "Site Access"
This was already set to allow access "on all sites"
nevertheless, I clicked on "on all sites" again, and then suddenly the blue icons appeared in the login box on the page I was viewing. I tried another... loading this forum in Incognito Mode, and the blue boxes appeared and my credentials were filled in!
Maybe a bug with Chrome? Even though allow access "on all sites" was ticked, reselecting it SEEMS to have cured the issue. Thank goodness. Having easy access to your password manager is invaluable these days.
I'll see if it works, now, on the PCs as well, in the morning.
Cheers, and thanks.
Vindy
Level 8
Report Inappropriate Content
Message 5 of 10

Re: TrueKey stopped working in Chrome on all my PCs (and Mac)

Jump to solution
No, I spoke too soon.
While I tested it on several websites, and the blue icons appeared on each when I tried to sign in, upon closing Chrome and reopening it, I no longer see the blue icons in the password boxes when attempting to sign in to web sites.

I even went back to manage extensions, clicked on manage all sites. Didn't help.
I also tried clicking on allow on the site I was currently visiting. This also didn't work. I then went back to allow on all sites. Still not working.
Got my hopes up there. It's the first time it'd worked at all in weeks.
What a weird issue.
Vindy
Level 8
Report Inappropriate Content
Message 6 of 10

Re: TrueKey stopped working in Chrome on all my PCs (and Mac)

Jump to solution

I was just trying to retrace my steps, disable TrueKey access in Incognito Mode and then close Chrome and try again, but I noticed I've been signed out of TrueKey and am unable to sign in again, saying it's unable to connect to TrueKey servers, and giving me the option to run it offline.

 

Oh wait... while typing this message, the extensions icon has just changed from black/off back to blue again on its own. 

There are obviously some issues going on right now, so I'll save myself some frustration and save this for another day, except that...... out of interest I went to one of my saved sites.... bt.com

I clicked to login and.. .the blue truekey icons are in the password dialogue boxes, and the credentials have been automatically filled in!

Now, is this because I disabled and reenabled Incognito Mode / All Sites access again, or is it because of the connection issues TrueKey seems to be having?

Again, I'll leave it for now. not the way I'd planned on spending a Saturday night!

At least I've seen it working sporadically, so I have hope the issue will get resolved.

Vin.

Vindy
Level 8
Report Inappropriate Content
Message 7 of 10

Re: TrueKey stopped working in Chrome on all my PCs (and Mac)

Jump to solution

One last reply to myself, I HAVE found a way to make it work.

After sending the last message I continued to use Chrome to browse the web.
We have a number of Google accounts here, so when I visited gmail, sure enough TrueKey listed all our saved gmail credentials. Once it starts to work, it continues to work until.... Chrome is closed, and reopens. Then TrueKey fails to work!

I've tried fiddling with the site access controls. No, that's not it.
BUT, I have found a way to make TrueKey work, but I have to do this every time I start TrueKey.
Stupid as it sounds.

If I visit a site with a login page. To keep it simple, the local IP address of my router... no TrueKey icons and credentials are not completed.

Right Click on the TrueKey Extensions icon, go to Manage Extensions.
Scroll down and toggle the Allow In Incognito switch.
Go back to the original tab with the logon screen.
The blue TrueKey icons appear, and now TrueKey continues to work, until I close Chrome!

Sounds crazy, but I guess it's a bug in Chrome (?)
So it seems that so long as I do that, I can use TrueKey.
Not perfect, but it's a workaround!

 

EDIT: and I just did it again. It doesn't matter if I start Chrome with the extension set to allow in incognito mode, or not.  If I load Chrome and visit a login screen, no truekey. Manage extensions, toggle the incognito switch, go back to the tab with the login screen and within a second the blue icons are back, and the credentials are completed!

 

EDIT 2:

Really last post/edit.

I am now typing this on my (Windows 10) Surface tablet.  I booted it up, had to sign back into TrueKey (took many attempts of TrueKey servers not responding) but made it in the end.  Visited my router login page, no TrueKey!  Went to the Extensions Management, toggled the Incognito Mode option, went back to my router login page, had to refresh this time, and now TrueKey IS working.  Same as on the Mac.

I then visited some other sites, including this forum, and was automatically signed in each time.

 

Also for reference... I mentioned that I need to toggle the option to allow incognito mode to work with TrueKey to get it to work at all.  I can toggle it back to its original position after TrueKey has started working, and TrueKey will continue to work... until Chrome is closed.  Then I need to toggle the control again.

Vindy
Level 8
Report Inappropriate Content
Message 8 of 10

Re: TrueKey stopped working in Chrome on all my PCs (and Mac)

Jump to solution
OK, next day now.
I'm sitting at my main workstation, running Win 10 Pro 64bit.
I just loaded Chrome, visited a site with a login. No TrueKey.
I right clicked on the TrueKey Extensions icon, and selected Manage Extensions.
I toggled the "allow in incognito" switch off and on.
Then I went back to my original tab with the login screen, refreshed the page, and now TrueKey is working.
So that's the same across a Mac and two PCs now.
The question is, how to get it to run permanently?
Vin.
Vindy
Level 8
Report Inappropriate Content
Message 9 of 10

Re: TrueKey stopped working in Chrome on all my PCs (and Mac)

Jump to solution

OK, I think I've fixed it myself, now.

I was just thinking.... what do all of these systems have in common that could cause this issue?
I mean, it was even not working on Mac OS, as well as all my separate Windows PC. Can't be cookies, can be.... extensions? I have TrueKey running in Chrome, and Chrome installs the same extensions across all Chrome installs on your Google account.

I was looking at the web interface login screen for one of my internal devices.
All extensions are disabled. AdBlock, Ghostery.... etc. But TrueKey still didn't work (unless I did the aforementioned toggle of the Allow In Incognito Mode which appears to restart TrueKey and then it works until Chrome is restarted)
What if another extension is starting up and messing up TrueKey?

So, I went to my extensions in Chrome. I had 5 or 6 that I haven't used for years. They were disabled, but not removed.
I had thought that when they're disabled, they can't cause any issues.

WRONG.

All of the old extensions that I no longer use have been removed. I can't say which one caused the issue, because I removed a whole lot at once.

I went back to the webinterface page, refresh... TrueKey is alive!

I visited the URL for this forum, TrueKey signed me in!

I closed Chrome. Revisited my web interface. TrueKey worked immediately.

So, one of the disabled extensions was somehow blocking TrueKey.
Changing the Incognito Mode setting seems to have restarted TrueKey and made it work, so perhaps an extension was updated in Chrome, and started after TrueKey, and somehow blocked it, despite the fact it was disabled.

This is the best I can come up with right now.

There's no need to have old, disabled extensions lying around anyway, It's probably a security risk in itself. I'm still surprised that a disabled extension can cause an issue but..... I seem to have found my own solution.
(I had even removed the TrueKey extension and reinstalled, and this didn't help)

Maybe this can help someone else in the future, and even if you're not having issues, consider removing all old/disabled extensions)

Thanks for reading.
Vin.

 

EDIT: Confirmed working on second system.  I have just booted up my Surface tablet (on which I am now typing this).  I allowed Chrome to start, I visited the local web interface  No TrueKey.  I checked installed extensions and noticed that all the extensions I'd removed using my workstation were now removed from Chrome on this machine, so I assume that the extensions started up during Chromes boot and were then removed.  So to test this, I closed Chrome, reopened it, revisited the local webinterface and TrueKey was working as it should.

So it would appear this did indeed fix my issue, even though as I mentioned above, the extensions that I removed were already disabled.  Thanks.

View solution in original post

jrbvt
Level 8
Report Inappropriate Content
Message 10 of 10

Re: TrueKey stopped working in Chrome on all my PCs (and Mac)

Jump to solution

TrueKey called me back after a couple of days: "backend issue" ... it has now been two days since they called me and I still can not get this to work on Chrome, Firefox, and Edge on my new PC or my rebuilt PC.  I have one PC that I never touched TrueKey over the past month and Chrome is broken there as well but I can get it to work on Firefox and Edge.

 

TK still works on my Android phone.

How Many Badges Can You Collect?
Ready for a little competition? Members like you are earning badges and unlocking perks for their helpful answers. Are you? Click here to find out.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community