cancel
Showing results for 
Search instead for 
Did you mean: 

Limiting password entry to specific URL?

I use TrueKey for work, and to keep logins for my test sites. But I have run into the problem that it will autofill any password-field it finds on the domain.

So I want to use it to log into the site: https://xxx-apps.staging.xxxx.xx/session/new?ReturnUrl=%2F

But once logged in, I do not want to autofill password fields on sub-pages. We have a user management page on the site, and whenever I open a User's page (https://xxxx-apps.staging.xxxx.xx/brugere/e1ad8635-c58c-0000-81bd-a95900d46695/edit), it auto fills the password field, and if I forget to remove it, the user's password changes when I save.

It would be nice if I could force it to only autofill on the specific URL I have saved in True key.

4 Replies

Re: Limiting password entry to specific URL?

Hi @StormenDK 

Try the below steps which will help you to block storing passwords within sub-domains

  • Open True Key
  • Edit the individual credential
  • Click Advanced option on the top right (screenshot)
  • Disable "use for the www.gmail.com subdomain only"

TK subdomain.PNG

 

 

 

 

 

 

Regards
Siva

Re: Limiting password entry to specific URL?

I tried that but it didn't work. It still fills in the password on any page on that domain that has a password field. 

McAfee Employee marcd
McAfee Employee
Report Inappropriate Content
Message 4 of 5

Re: Limiting password entry to specific URL?

This is indeed an issue that is known to us. We have added it in our backlog to fix and it is uncertain at this point as when it will be fixed.

Thanks,

Marc D.

If this information was helpful in any way or answered your question, please mark it as the accepted solution and give Kudos if appropriate.

McAfee Employee marcd
McAfee Employee
Report Inappropriate Content
Message 5 of 5

Re: Limiting password entry to specific URL?

Good morning,

I wanted to provide further explanations on how the instant login feature settings work as per design:

There are two level of settings for instant login.

  1. Global settings (settings- App settings)
  2. Individual Asset level settings (Edit an asset, go to Advanced tab and disable Instant log in)

Individual asset level setting overrides global setting.

This means if an user disables "Instant Login" on a given asset, then TK will fill the credentials but TK won't do instant log in (submit). This is as designed.

Otherwise if an user enables "Instant Login" on a given asset, TK does instant login. This is as designed.

Thanks,

Marc D.

If this information was helpful in any way or answered your question, please mark it as the accepted solution and give Kudos if appropriate.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community