cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrading tie server 1.3 to 2.0

Hi,

I'm upgrading tie server 1.3 to 2.0. I'm following this article https://kc.mcafee.com/resources/sites/MCAFEE/content/live/PRODUCT_DOCUMENTATION/26000/PD26039/en_US/...

When running the vacuum analyze operation I'm getting error. Is this something critical? Can I continue with upgrade?

ScreenHunter_289 Mar. 20 10.15.jpg

2 Replies

Re: Upgrading tie server 1.3 to 2.0

I can't say if it's critical, but if you have the time, I would suggest running 'VACUUM FULL' instead.

VACUUM FULL fully locks the database, so TIE will be down for the duration of the vacuum, and it will take several hours to complete, but may be able to fix this particular issue.  Note that you need to run "service tieserver stop" to bring TIE down, and then "service tieserver pg_start" to bring up just the Postgres database.

That said, if you want to understand the severity of the issue, I would recommend contacting support.

Highlighted

Re: Upgrading tie server 1.3 to 2.0

I contacted the support and they said to run these commands which resolved the error.

tie=# SET zero_damaged_pages = on;

tie=# VACUUM FULL ANALYZE

No problems with upgrade after that.

More McAfee Tools to Help You
  • How-to: Endpoint Removal Tool
  • Support: Endpoint Security
  • Visit: Business Service Portal
  • More: Search Knowledge Articles
  • ePolicy Orchestrator Support
  • The McAfee ePO Support Center Plug-in is now available in the Software Manager. Follow the instructions in the Product Guide for more.