cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot install TIE 1.2 VSE module

Jump to solution

Environment

Workstation windows 7
Mcafee Agenr 5.0.2.333

VSE 8.8.0.1528

Hi,

Could anyone help me with this issue.

I am trying to install TIE VSE module on the environment above for the first time and everytiime i try to do so i get the following error;

"Mcafee Threat Intelligence Exchaange module for VSE setup failed"

I have also tried to install it manually which produces the same error but the TIESetup.log file has the following error

"

Property(S): ISVROOT_PORT_NO = 0

Property(S): IS_COMPLUS_PROGRESSTEXT_COST = Costing COM+ application: [1]

Property(S): IS_COMPLUS_PROGRESSTEXT_INSTALL = Installing COM+ application: [1]

Property(S): IS_COMPLUS_PROGRESSTEXT_UNINSTALL = Uninstalling COM+ application: [1]

Property(S): IS_PREVENT_DOWNGRADE_EXIT = A newer version of this application is already installed on this computer. If you wish to install this version, please uninstall the newer version first. Click OK to exit the wizard.

I have never installed TIE on this system so i find this a bit strange.

has anyone got any ideas why this is happening

I have attached the setup log for further investigation

Many thanks

Spookrider

1 Solution

Accepted Solutions
tkinkead
Level 12
Report Inappropriate Content
Message 10 of 16

Re: Cannot install TIE 1.2 VSE module

Jump to solution

That's right, DXL is required for TIE.

15 Replies
tkinkead
Level 12
Report Inappropriate Content
Message 2 of 16

Re: Cannot install TIE 1.2 VSE module

Jump to solution

There is no TIE for VSE 1.2 module.  Which one are you install, exactly?

MSI (s) (38:A4) [16:27:43:370]: Doing action: ValidateDependencies

Action ended 16:27:43: ISSetupFilesExtract. Return value 1.

MSI (s) (38:94) [16:27:43:370]: Invoking remote custom action. DLL: C:\Windows\Installer\MSI8191.tmp, Entrypoint: VerifyDependencies

Action start 16:27:43: ValidateDependencies.

[16:27:43:386] Log: Error detecting DXL, RegKeyOpen failed 2

CustomAction ValidateDependencies returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)

MSI (s) (38:A4) [16:27:43:401]: Note: 1: 33

Action ended 16:27:43: ValidateDependencies. Return value 3.

It's failing on ValidateDependencies.  Do you have the DXL client installed on the system?  "Error detecting DXL", the TIE installer doesn't see that it's present.

damiafaw
Level 10
Report Inappropriate Content
Message 3 of 16

Re: Cannot install TIE 1.2 VSE module

Jump to solution

There is only 1.0.1.140 version available for TIE VSE (need the DXL also, version 2.0.1.162) - both of these go on the desktop/laptop.

There is the TIE Server 1.2 version however, which is the OVA files or update files for the McAfee linux server and thats not for your desktop/laptop machines.

Re: Cannot install TIE 1.2 VSE module

Jump to solution

HI,

Thank you for getting back to me.

I have not got the DXL client installed on the system which i properly would suspect that is the reason why it keeps failing and the TIE VSE version i am trying to install is 1.0.1.137 which keep failing.

I have also tried lookiing for the DXL client for windows but could not see it, is it hidden in one of the packages????

many thanks

Spookrider

Re: Cannot install TIE 1.2 VSE module

Jump to solution

HI,

The DXL client is not installed on the clients, is this a seperate package for TIE 1.2, i cannot seem to find it and is there instructions for installing TIE 1.2????

Thanks inadvance

Spookrider

tkinkead
Level 12
Report Inappropriate Content
Message 6 of 16

Re: Cannot install TIE 1.2 VSE module

Jump to solution

The Data Exchange Layer client is in a separate category, both on the McAfee Downloads page and through the Software Manager.  You must have the DXL client installed before installing TIE.

TIE 1.2 is the version number of the TIE Server software.  This is only for deployment on your TIE OVA.

The latest version of TIE for VSE is 1.0.1.140.  There is no "TIE 1.2" that can be deployed on clients.

Re: Cannot install TIE 1.2 VSE module

Jump to solution

HI,

Thank you for getting back to me.

Can you please point me in the right direction where the DXL client would be in the downloads??????

Thanks inadvance

Spookrider

tkinkead
Level 12
Report Inappropriate Content
Message 8 of 16

Re: Cannot install TIE 1.2 VSE module

Jump to solution

Data Exchange Layer 2.0 at the bottom

ePO

Re: Cannot install TIE 1.2 VSE module

Jump to solution

Ahh, thanks for that
i suppose once this is installed i can then install the TIE VSE module on the clients, is that correct?????

tkinkead
Level 12
Report Inappropriate Content
Message 10 of 16

Re: Cannot install TIE 1.2 VSE module

Jump to solution

That's right, DXL is required for TIE.

More McAfee Tools to Help You
  • Subscription Service Notification (SNS)
  • How-to: Endpoint Removal Tool
  • Support: Endpoint Security
  • eSupport: Policy Orchestrator