Showing results for 
Search instead for 
Did you mean: 
Level 7

Very Slow Updates - Like 3 weeks and not yet finished

About 3 weeks ago I noticed a cross on the McAfee Icon, hovered, and it said  - you guessed - "You are not protected"  Went to Fix and a day later nothing had changed. Did a system restore to a much earlier date, everything came right and then a couple of days later it was all back to "Not Protected" Checked in security centre, clicked "Fix" and a window appeared saying updates are being loaded in the background, do not turn off your computer. Fine. Left it to do its thing but 3 weeks later the status hasn't changed - still suppodedly loading updates, Virtual Technician wont load, and trying to uninstall the software produces a blank window. Machine is fairly new Acer with Vista, Defender hadn't been running when this arose, but has now been switched on. Does anyone have an answer or suggestion. Bob

0 Kudos
1 Reply
Level 21

Re: Very Slow Updates - Like 3 weeks and not yet finished

It sounds like a corrupted file to me.

This might benefit form running the Virtual Technician to see if it can fix things.  If that doesn't work then do as follows:

Enable Windows Firewall as a precaution

Uninstall all McAfee products via Control Panel/Programs/Uninstall a Program

Run the MCPR removal tool


Reinstall everything from your online account.

I trust your Vista is SP2?  I ask because support for Vista (no service packs) has ended.

Message was edited by: Ex_Brit on 09/05/10 7:26:04 EDT AM
0 Kudos