cancel
Showing results for 
Search instead for 
Did you mean: 
cal2050
Level 7

SecurityCenter 10.5.204 Firewall not allowing Firefox to connect but does allow IE

I was hoping some of you educated people may be able to help me out.

I have always used FF as my home web browser and all of a sudden, yesterday (10/30), it stopped connecting. I can use IE with no problems but no FF. I uninstalled FF with Revo Uninstaller and reinstalled it but it still did not work. However, when I disabled my firewall, I was able to connect to the Internet using FF. I downloaded Firefox 3.6.1.2.

The McAfee products I am using are SecurityCenter 10.5.204 with Security Scan Plus 2.0.181.2.

I would hope it is a simple fix but I cannot figure out what to do. I have checked out many different forums but I figured this would be my best bet. Any and all assistance would be greatly appreciated.

Message was edited by: cal2050 on 10/31/10 2:43:06 PM CDT

Message was edited by: cal2050 on 10/31/10 2:43:49 PM CDT
0 Kudos
6 Replies
Aldrin
Level 12

Re: SecurityCenter 10.5.204 Firewall not allowing Firefox to connect but does allow IE

Open McAfee Security Center> Click on Firewall> Settings> Click on Program Permissions> Make sure Firefox has given Full Access over there

Pro Per.JPG

0 Kudos
cal2050
Level 7

Re: SecurityCenter 10.5.204 Firewall not allowing Firefox to connect but does allow IE

Aldrin,

Thanks a lot for the help. I was able to connect, finally, last night after troubleshooting since Saturday. However, I do not have a Firewall settings tab or button...or it is not obvious. My screen does look similar to the pic that you posted in your response but I did not see the Settings options anywhere. I did get it to work by clicking the Restore Defaults button but I wasn't sure that was the best idea since I did not know the exact issue that created the problem.

Do you think I may have a virus or a trojan now and is that what may have triggered the issue?

Thanks again

0 Kudos
Dinz
Level 16

Re: SecurityCenter 10.5.204 Firewall not allowing Firefox to connect but does allow IE

Hi cal2050,

It need not to be a virus that blocked  your firefox connecting to internet , could be a incorrect setting with the firewall that coould have caused the issue there. Moreover, You can quickly restore Personal Firewall to its original protection settings. Restore resets your security level to Trusting and allows outbound-only network access, enables Smart Recommendations, restores the list of default programs and their permissions in the Program Permissions pane.

We are glad that your issue is resolved and please get back to us if you have any other issues.

Try to run Mcafee virtual technician from here : http://mvt.mcafee.com and check if it reports any errors with the product so as it would auto-correct it or provide us with more information, please post your session id here  If there are any issues detected by McAfee virtual technician.

Regards,

Dinesh K

McAfee Online Community Moderator

0 Kudos
cal2050
Level 7

Re: SecurityCenter 10.5.204 Firewall not allowing Firefox to connect but does allow IE

Thanks, but I had trouble with that Virtual Technician.....it looked like it was searching for a long time....over 24 hours and it did not help me solve the issue.

0 Kudos
Dinz
Level 16

Re: SecurityCenter 10.5.204 Firewall not allowing Firefox to connect but does allow IE

Hey cal2050,
If you are still facing issues after the recent McAfee update could you please click on this link and get connect to our chat technicians so that they would diagnose the issue thorugh a remote sharing procedure and find out the fault and get it resolved for you.


Regards,
Dinesh K
McAfee Online Community Moderator

0 Kudos
newjack
Level 12

Re: SecurityCenter 10.5.204 Firewall not allowing Firefox to connect but does allow IE

Also when you click on the left firewall,then settings on right -smart advice & advanced settings,check that enable protection during start up is checked.I know on mine,if you restore defaults.This item will untick itself.            newjack

0 Kudos