cancel
Showing results for 
Search instead for 
Did you mean: 

Security Center blank, Virtual tech blank, mcupdate.exe appears not to run

New 64-bit Dell with 30-day McAfee Security Center and IE 8 with factory defaults.

Windows 7 Action Center is prompting me to run mcupdate.exe. I click, "Yes I trust this publisher..." and nothing happens. I've tried running mcupdate.exe from a DOS prompt as Administrator and nothing happens either.

When I open Security Center, I get a blank white panel in the middle of the screen, nothing more. This happens whether I attempt to open from the taskbar or from Start.

I download and run McAfee Virtual Technician. It opens a screen with a Windows frame, a gray border with "Virtual Technician at the top," and a white canvas with a gray border. Then it just sits there.

Task Manager shows McAfee Security Center (mcagent.exe) and McAfee Virtual Technician Installer (MVTInstaller.exe *32) running.

Services shows:

McAfee Application Installer Cleanup, (not running, Automatic)

McAfee Firewall Core Service, Started

McAfee Network Agent, Started

McAfee OOBE Service, (not running, Disabled)

McAfee Personal Firewall, Started

McAfee Proxy Service, Started

McAfee Scanner, (not running), Manual

McAfee Services, Started

McAfee Validation Trust Protection Service, Started

McAfee Virus Scan Announcer, Started

McShield, Started

3 Replies
Reliable Contributor exbrit
Reliable Contributor
Report Inappropriate Content
Message 2 of 4

Re: Security Center blank, Virtual tech blank, mcupdate.exe appears not to run

IE8 at factory defaults wouldn't cause this but IE9 beta would, defaults or not, has it been installed at any point?   Or has any other beta application such as a beta service pack been installed?  That wouldn't be compatible either.

If the answer to all those is no then I would simply try uninstalling via Control Panel, running MCPR removal tool (Useful Links at the top of this page), rebooting and reinstalling directly from your online account.

Message was edited by: Ex_Brit on 08/02/11 6:28:25 EST PM

Re: Security Center blank, Virtual tech blank, mcupdate.exe appears not to run

Attempt to uninstall, either via Control Panel or Start menu, results in the same blank white panel in the middle of the screen.

But running MCPR.exe directly, without prior uninstall, seemed to have removed all McAfee products. I was able to successfully install my standard configuration antivirus product (not McAfee).

Thanks for the assistance!

Message was edited by: rtmerrill on 2/8/11 7:34:27 PM CST
Reliable Contributor exbrit
Reliable Contributor
Report Inappropriate Content
Message 4 of 4

Re: Security Center blank, Virtual tech blank, mcupdate.exe appears not to run

Are you fully up to date with Windows Updates both critical and non-critical?  Also check that Adobe Flash and Shockwave are up to date and Java also.  I find it ofdd the uninstaller would also be blank.

Have you been using registry cleaners?   They can corrupt legitimate files quite easily.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community