Showing results for 
Search instead for 
Did you mean: 
Level 7

Net adapter not working and issue with Windows update

My issue is that after uninstalling McAfee Security Center and running the MCPR took, my network adapter stopped working leaving the affected PC without internet access.  Please help.  (BTW, I'm posting from another PC in my home.)

Here is the background...

I am running XP Media Center, Version 2002, SP3

My issue started with Windows update not working.  Tried several things including opening a discussion with Microsoft Answers.

The Microsoft agent thought perhaps a McAfee update had not installed properly (sorry folks) and recommended that I uninstall and reinstall McAfee and then try again to fix Windows Update.  Well, after using Add/Remove Programs and then MCPR, my network adapter stopped working.  It wasn't just that I could not get on the internet, the networking icon on the taskbar complained and I could see issues when I checked Device Manager.

The Microsoft agent thought I had malware and referred me to a malware forum.  The agent in Malwarebytes forum went through many steps with specialized SW and decided I did not have malware.  So, then I decided to post on this (McAfee) forum as I think my issue is related to McAfee SW.  (I can post links to the Microsoft Answers and Malwarebytes discussions if you like.)

So, here is my current status...

In device manager, I see three network adapter even though I only have one physical adapter installed.  Here is the screenshot.


You can see that two of the adapter entries refer to McAfee.  I thought I could uninstall all three devices and reinstall and then be back in business.  Here is what happens when I try to uninstall any of these three items in any mode (normal boot, Safe Mode with networking, Safe Mode w/o networking):

"Failed to uninstall the device.  Device may be required to boot up the computer."

If I assume that the uninstall procedure worked properly and then try to reinstall the driver anyway, I get:

"A problem occurred during hardware installation.  Your hardware might not work properly."

For the "regular" network adapter entry, the Properties screen says:

"The device is not configured correctly. (Code 1)"

For the two entries that include "McAfee" in the text, the Properties screen says:

"Windows cannot start the hardware device because its configuration (in the registry) is incomplete or damaged.  (Code 19)"

So, I'm thnking that my McAfee unistall using Add/Remove Programs and MCPR is still not complete and, as a result, something in the registry is hosed.  Perhaps if we can clean up the registry, I can then do a clean uninstall and reinstall of my network adapter and restore internet access, then reinstall McAfee, then try Microsoft's instructions to get Windows Update to work again.

What are your thoughts?  Thanks for your help!

0 Kudos
2 Replies
Level 7

Re: Net adapter not working and issue with Windows update

I had a similar problem that was caused by something else not related the McAfee.  I fixed it by resetting the network adapter.  The instructions for Windows 7 are here:

For other systems I think you can go to Device Manager, select the appropriate network adapter and do a repair.  Also, have a look at and

If none of this helps then it's possible the network adapter has failed and you need to replace it.

Message was edited by: astor on 9/10/11 6:09:09 PM
0 Kudos
Level 7

Re: Net adapter not working and issue with Windows update

PROGRESS!  YES!  astor, thanks for your help!

The network adapter works now and I'm coming to you from the formerly-affected PC!

Honsestly, I would not have thought of looking for articles about missing icons.  Good call.  I did several of the steps in 825826:

General troubleshooting:

Method 2 - Everything was OK except that Step 5, Simple TCP/IP Services was not checked.  When I checked it, I got error messages.  However, after doing some of the other Methods, I came back to Step 5 and it worked.

Advanced troubleshooting:

Method 1 - Worked fine

Method 4 - Worked fine

Method 5 - I did not change anything because everything looked okay already as far as I could tell.

Method 6 - Had one gosted network adapter but XP would not let me remove it.  So, I left it as is.

Method 7 - Worked fine

At this point, I tried uninstalling and reinstalling the network adapter.  Everything went smoothly and I could then surf the web.  I went back and tried Method 2, Step 5 and that step worked fine.  So, having done several steps before trying to uninstall and install the network adapter, I don't know which step actually solved the issue.

THEN, I reinstalled McAfee Security Center and kept manually updating it until it said everything was up-to-date.

Device manager now ONLY shows the actual network adapter, it does not have the entries that have "McAfee" in the name.  Well, I suppose they could be hidden (Method 6 above) but I did not bother checking.

So, I'm still left with Windows Update not working.  I need to try a couple more steps the Microsoft Answers agent recommended.  If that does not get Windows Update working error-free, then I'll open a topic on Microsoft Answers.

Let's leave my thread here active for a couple of days.  I want to use the PC a bit to make sure it is stable.  After that, I'll likely click on "Correct Answer" and then set about working on Windows Update again.

0 Kudos