cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
dj501
Level 7
Report Inappropriate Content
Message 921 of 1,143

Re: McSvHost.exe causes error on Shutdown

we are talking about nothing

Usb devices was present also in ver. 9 of mcafee and no error appeared.

Same for Win XP.

I have the same software installed on pc since 2 years and no problem was since YOU pass from ver 9 to 10.5

So where is the problem? On my usb devices? On win xp?

NO is simply a new mcafee version NOT tested. And this is not ammissible for an antivirus.

However i have obtained my money back and i can find another antivirus after SIX years of mcafee.....

make your considerations...

Bye

Re: McSvHost.exe causes error on Shutdown

dj501

I do not know where you got that idea from as the issue is caused by mcafee ver 2010 as mcsvhost is a new program only in 2010 version. I / mcafee never said it was your usb problem it was just that mcafee had problems getting memory when closing down when a usb hardware was active.

Still say the issue was so minor that one should not leave because of it. But of course that was your right. Got another popup on my test PC. 1 in 14 shutdowns. It is on 10.5

Good luck with your new AV.

davideo0
Level 7
Report Inappropriate Content
Message 923 of 1,143

Re: McSvHost.exe causes error on Shutdown

As can be seen from this forum, there are many people here who are aware that the error which repeatedly appears on shutdown is related to McAfee but there must be many thousands who are not au fait with computer matters who are worrying why their computer is showing an error on a regular basis.

For the benefit of those people who do not complain and who think the problem is theirs, it would have been nice if McAfee had informed all their clients that the error they may be experiencing was an error know to McAfee and which McAfee are attempting to clear.

Re: McSvHost.exe causes error on Shutdown

Good point there is a post on the main forum but one has to find it first. Will ask if a post on main web page possible

Message was edited by: Peacekeeper on 12/07/10 5:12:16 PM
davideo0
Level 7
Report Inappropriate Content
Message 925 of 1,143

Re: McSvHost.exe causes error on Shutdown

Most of the people I was referring to would never think to look at the McAfee web related pages. Why would they? - they do not connect the problem with any one in particular.

The most effective option and the cheapest would be for McAfee to simply email their database of customers.

Message was edited by: davideo0 on 7/12/10 2:48:39 AM CDT
MagicLight
Level 7
Report Inappropriate Content
Message 926 of 1,143

Re: McSvHost.exe causes error on Shutdown

Over the past couple weeks, my 2 XP and Vista systems have all updated to 10.5.  Though I never had the error issue with Vista,  both XP systems had it every time.  Not only has this latest version fixed that issue, but it also took care of the ever reappearing icon on your desk top.  At last, but I think I will still look for another security software package.  I can get CA free with my Road Runner, but I am paying for this?

ReB
Level 7
Report Inappropriate Content
Message 927 of 1,143

Re: McSvHost.exe causes error on Shutdown

Was getting the same error..

Was very pleased with it as I allready was kindda annoyed with McAfee.

Updating is a nightmare (takes forever) and have to re-install frequently after a update..

Also it seems impossible to mannualy download DAT's as none ever find a competable version on my system???

The new UI is most unpleasant and I never asked for it. Was perfectly happy with 2009 (exept updating) which is what I bought....

Quick Clean (as is everything else) is inconveniant to get to and what happened to my beloved Trace??

Once my subscription runs out I'm going to get another AV..

Been using McAfee for at least a decade but no more...

As for the current problem:

I solved the popup appearing by changing 2 services.

Both McAgent and SiteAdvisor are started during startup and by default are set on Automatic.

As there is no need for either to do that, I changed these to Manual (didn't wanna completely disable them, just in case) and its gone...

Both however are still running, only difference is the error being gone....

Bonus is the lesser use of memory..

Hopes this helpes..

Graffin75
Level 7
Report Inappropriate Content
Message 928 of 1,143

Re: McSvHost.exe causes error on Shutdown

Nice to know that a 1000 posts later, the problem STILL hasn't been resolved.

My XP desktop STILL gets the error (even after the latest update). It happens less frequently (like every 2nd or 3rd restart/shutdown), but it's still annoying.

Furthermore, I just bought a brand new Asus laptop with Windows 7 Pro (64-bit), so I thought i'd try McAfee on there (since it has 3 licenses). While, there's no dialog box popping up, I have noticed Win7 informing me that a task was still running (McSvHost.exe) and automatically closed it before shutting down. It's only popped up a couple of times, but it doesn't inspire a lot of confidence in the product.

Not only that, but under Win7, the action center flag reports I have no antivirus, no anti-spyware and no firewall running. It takes about 3-5 minutes for McAfee to actually "kick in" and the warnings to disappear from the action center. I guess that means i'm unprotected for those few minutes.

I've used McAfee for many many years, but i'm absolutely fed up with its poor performance.

And yes, I did clean installs on both my desktop & laptop. I used MCPR.exe. I even downloaded the latest builds from my McAfee user account.

The problem is obvious. It's the McSvHost.exe service. It wasn't there in McAfee 2009 or earlier versions, so is it really necessary for the 2010 release? We've all been more than patient and gone through the BS of uninstalling/reinstalling/talking with technicians only to get nowhere, because the fault lies in the McAfee software.

I give up. Time to go back to Norton or try Trend Micro.

on 7/22/10 4:51:26 AM CDT

Re: McSvHost.exe causes error on Shutdown

I use win7 64 as does peter (Ex_brit) mcafee is stable on it loads immediately and except for a couple users with a bsod is very stable.. When you said you used MCPR was this after you had the issue ie install/see issue/uninstall/reinstall/ still have issue path? This is new on me if so will ask Peter and our techs.

Graffin75
Level 7
Report Inappropriate Content
Message 930 of 1,143

Re: McSvHost.exe causes error on Shutdown

Hey Peacekeeper, thanks for the post.

Yeah, I too experienced my one and only BSOD on my brand new laptop and that was whilst running a scan with the just installed McAfee.

The laptop is brand new and came with a Trend Micro trial, so I uninstalled that, rebooted, logged into my McAfee account and installed Total Protection 2010 from there.

Not only has McAfee really slowed down startup, but like I said, it doesn't actually "kick in" til a few minutes after startup, and that's considering there's only the bare minimum loading at startup (i've checked under startup and msconfig).

And yes, on shutdown it appears the same process that is causing havoc on my XP system doesn't seem to always shut itself down on Windows 7 either.

As for the BSOD, I think I can explain that. My laptop has Intel video on-board along with an nVidia GT330M, and depending on what power saving settings I use, it uses one or the other. I believe I had it using the on-board video when I ran the scan and about 6% into the scan, it blue screened and began to do a memory dump. When I attempted to restart Windows normally, it shat itself. I had to reboot a second time to actually get back into Windows 7 (let's just say it caused a brief anxious moment). It's got 4Gb of 1066MHz DDR3 RAM so it's not like it's underpowered. It still shouldn't have blue screened because nothing else was running except for the scan.

I'm sorry, but i've lost all confidence in McAfee. Unless McAfee removes that problematic process, there's no way i'll trust any of my PC's security to a flawed piece of software. I've had nothing but trouble with MTP 2010.

When I used MCPR, it was on my desktop (running Win XP SP2 - 4Gb RAM, 3.0GHz CPU). As i've said. Never had issues with Total Protection 2007, 2008, 2009. 2010 introduced McSvHost.exe, and that's where the problem lies.

Message was edited by: Graffin75 on 7/22/10 6:21:09 AM CDT
How Many Badges Can You Collect?
Ready for a little competition? Members like you are earning badges and unlocking perks for their helpful answers. Are you? Click here to find out.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community