cancel
Showing results for 
Search instead for 
Did you mean: 
tomica
Level 7

Deactivate McAfee - Bufferoverflow alert in Excel with eurotool.xla add-in and Workbook_Open macro

How can I temporarily deactivate McAfee Antivirus Plus for test purposes on Vista SP2? When I rightclick the icon in the systray I don't see "deactivate" that everyone onvarious internet help sites talks about.

McAfee has suddenlyout of the blue stopped Excel (Office 2003) from opening to prevent a bufferoverflow – for, as far as I can determine, for 2 separate reasons…

if the Excel Add-in eurotool.xla is activated (it has been for years, now today McAfee hastaken exception to it). If I deactivate the Add-in Excel works OK again.

When an Excelfile with a Workbook_Open macro is opened. I has worked perfectly for years,now today McAfee has taken exception to it. An individual McAfee scan of thefile is negative. If I deactivate the Workbook_Open macro the file can beopened OK again.

I'd be mostgrateful for assistance. Thanks in advance.

0 Kudos
4 Replies
exbrit
Level 21

Re: Deactivate McAfee - Bufferoverflow alert in Excel with eurotool.xla add-in and Workbook_Open macro

That right-click deactivate is to deactivate the subscription for that machine.  If you clicked it then you'll have to activate it again.

You mean temporarily disable I think?    Double-click the taskbar icon to open SecurityCenter

Click Virus and Spyware Protection

Click Real-Time Scanning

Click Turn Off and select for how long

(If you are going to be rebooting a few times select never).

Don't forget to turn it on again.

You can do the same with Firewall in the Web and Email Protection 'drawer'.   However, that shouldn't be necessary.

You might want to contact Technical Support and file a bug with them about this.  It's a free phone call or online chat session.

Linked under Useful Links at the top of this page.

Message was edited by: Ex_Brit on 15/08/12 6:33:59 EDT AM
0 Kudos
exbrit
Level 21

Re: Deactivate McAfee - Bufferoverflow alert in Excel with eurotool.xla add-in and Workbook_Open macro

Moved discussion to SecurityCenter as a more appropriate spot.

0 Kudos
tomica
Level 7

Re: Deactivate McAfee - Bufferoverflow alert in Excel with eurotool.xla add-in and Workbook_Open macro

Hi Ex Brit,

Many thanks, but unfortunately your suggestion was unsuccessful. Evenwith Real-Time Scanning deactivated, Excel gets closed and the McAfee buffer overflow message appears.

Even if I deactivate "buffer overflow exploits"  the message comes up. Only if on the buffer overflow message I click don't prevent, does everything work OK. So this is definitely a McAfee problem, particularly as it manifested itself for the first time directly after yesterday's upgrade and reboot.

Same with the "Mfehidik" error I and many others are still getting it in the Event Manager. Why can't McAfee rectify this?

0 Kudos
exbrit
Level 21

Re: Deactivate McAfee - Bufferoverflow alert in Excel with eurotool.xla add-in and Workbook_Open macro

Don't ask me.  Support are the people who are supposed to know about these things.   Have you tried them on this latest thing?

0 Kudos