Showing results for 
Search instead for 
Did you mean: 

Case study - Internet communications fail after upgrading Security Centre...

I thought readers may be interested in the experience I had with solving this problem.

System details

Home user

Dell XPS 8300 running Windows 7 Ultimate with automatic upates

Large hardware configuration

McAfee Security Centre and its components, with automatic updates

Applications - primarily Microsoft and Adobe products

The problem

For the past three weeks I have been having this problem – exactly the same each time – in other words it could be replicated.

The problem occurs when McAfee Security Centre is automatically upgraded from Version 11.0.654 to Version 11.0.669 at which time all Internet communications are lost.  The only way I have been able to resolve this is by going back to an earlier Restore Point which reverts to the earlier version of McAfee Security Centre.  However, because of the automated McAfee update system this whole procedure has had to be repeated many times.

What I have done

I downloaded McAfee document ID TS100810 entitled “Unable to access the Internet after installing a McAfee Security Suite” and followed all these instructions.  The problem was not fixed.

I applied for email technical support but was directed to run Virtual Technician first.  After over two hours (not uncommon I read on the McAfee Community forum) it still hadn’t initialised so I cancelled it.  I found a document entitled “McAfee Virtual Technician 6.0.0 Walkthrough Guide” and installed a standalone version.  This initialised and ran very quickly and found one problem in the Registry which it automatically fixed.  This was done using version 11.0.654 of the Security Centre.

I then upgraded the Security Centre to 11.0.669 and ran Virtual Technician again but because there was no internet communications it could not run (I think the documentation should say this).


I went to the McAfee support website and selected “Chat and Email”.  It said I had to run Virtual Technician first.  I selected this and was told “it was not installed”.  It was of course installed.  I selected ‘Next to Run’ and after 30 minutes it still had not initialised so I cancelled it being a repeat of the previous times.

The conclusion was that I was not able to contact McAfee Technical Support using their standard process – not good.

I tried over the past three days to email McAfee support at varous addresses with no response - even after saying "best product why not best support".  I believe it to be sensible and couteous to inform McAfee of the problem in advance  so they can reasearch it prior to their response.

Final episode

In desperation I decided to uninstall the McAfee product in accordance with their bulletin "TS101331 - How to uninstall and re-install McAfee products" which worked well.  Then I downloaded a totally up to date version of the Security Centre (which was within my subscription date) and believe it or not it all came good!


McAfee really have to get their act together for home users.  In their technical support website they offer "Chat or Email".  Email appears not to be an option especially when asked to run Virtual Technician without an internet connection.  They need to publish an email address by country with clear guidelines as to what the problems appear to be.

In the past I have had one similar problem - also serious - and had to contact a McAfee VP.  I received a response in just a few minutes, and the support person fixed it within the hour - brilliant.  I was not prepared to use this procedure on this occasion because a) I managed to fix it myself and b) I believe the wider community, as reflected in this forum, should benefit from my exprience.

Final note

This posting is not meant to knock McAfee because I happen to believe they have a top product.  What they must address is their customer service, take notice of what their customers say (with appropriate feedback), provide appropriate user documentation to minimise customer calls, and provide a published email service (to licensed users) which is replied to in a timely manner.

Thank you...

0 Kudos
3 Replies
Level 16

Re: Case study - Internet communications fail after upgrading Security Centre...

Hi there,

We understand that you have  spent a lot of your time and efforts in  resolving this issue , please let us know if you are interested in a call back from us so that we may help you fix this issue through a call back. I have sent you an email with more information please have the same replied to proceed further .


0 Kudos

Re: Case study - Internet communications fail after upgrading Security Centre...

Thank you Dinesh for your interest.

Sometime later it would be great to have a call-back because such feedback is usually welcome by a supplier.

However we'll have to leave it for a week or so because I will be tied up on other commitments.


0 Kudos

Re: Case study - Internet communications fail after upgrading Security Centre...

Hi Dinesh,

You will never believe this but the system has lost internet access again - after I thought I was so clever!

However, what I can say is that it occurred directly after Microsoft Windows 7 update had downloaded and  installed 17 critical updates, then rebooted the system - all when I was asleep.  This may provide you (McAfee) with a clue ie The McAfee Security Centre update 11.0.669 was up and running well as I described then Windows 7 updates came along and disaster struck.

I hope this helps.

0 Kudos