cancel
Showing results for 
Search instead for 
Did you mean: 
paul.k
Level 10
Report Inappropriate Content
Message 1 of 5

Custom Parsed events not showing up in the views

Jump to solution

Dear Community,

I have write a small parser to capture some logs from a flat text file.

The data never appears in any views.

At the moment I am manually uploading sample files.

I set view to all time as the sample logs are a bit old.

Date insertion limits are disabled.

I can't figure out why it's not displaying the events.

Thank You

Sample log entry

17-01-05 12:30:45 439 DEBUG         xxx.xxxxx.blahs.blah.blah - access.jaeleno=123456789S

Sample rule.

The data source is configured as generic syslog

Data source rules get created

1 Solution

Accepted Solutions
paul.k
Level 10
Report Inappropriate Content
Message 5 of 5

Re: Custom Parsed events not showing up in the views

Jump to solution

Thank You for all your suggestions. They were very good, and I made sure to double check my self.

However, it was a simple typo that was not easy to spot.

If you notice the sample log uses two digits for year 17 not 2017. When my associate created the date mapping he used %Y instead of %y.

Once corrected all events began to appear. What's really interesting is the difference in the behavior between 9.6 an 10.X.

In 9.6 event's just disappeared.

In 10 they could only be viewed via the Events pane, the summary pane would never show any events.

I would open a ticket with McAfee but you all know how much they like to troubleshoot custom parsers, and probably would not consider this to be a issue with the engine it self.

SO it's solved every one thanks for you help.

4 Replies

Re: Custom Parsed events not showing up in the views

Jump to solution

hey Paul.

Have you rolled out that rule?

paul.k
Level 10
Report Inappropriate Content
Message 3 of 5

Re: Custom Parsed events not showing up in the views

Jump to solution

Yep, and as you can see in the last screen shot it's generating the Signature descriptions based on the ASP rule I made.

i'm a bit perplexed

Highlighted
xded
Level 12
Report Inappropriate Content
Message 4 of 5

Re: Custom Parsed events not showing up in the views

Jump to solution

Is this parser enabled on the Default policy tab or only for this datasource?

paul.k
Level 10
Report Inappropriate Content
Message 5 of 5

Re: Custom Parsed events not showing up in the views

Jump to solution

Thank You for all your suggestions. They were very good, and I made sure to double check my self.

However, it was a simple typo that was not easy to spot.

If you notice the sample log uses two digits for year 17 not 2017. When my associate created the date mapping he used %Y instead of %y.

Once corrected all events began to appear. What's really interesting is the difference in the behavior between 9.6 an 10.X.

In 9.6 event's just disappeared.

In 10 they could only be viewed via the Events pane, the summary pane would never show any events.

I would open a ticket with McAfee but you all know how much they like to troubleshoot custom parsers, and probably would not consider this to be a issue with the engine it self.

SO it's solved every one thanks for you help.

More McAfee Tools to Help You
  • Subscription Service Notification (SNS)
  • How-to: Endpoint Removal Tool
  • Support: Endpoint Security
  • eSupport: Policy Orchestrator
  • Community Help Hub

      New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

    • Find Forum FAQs
    • Learn How to Earn Badges
    • Ask for Help
    Go to Community Help

    Join the Community

      Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

    • Get helpful solutions from McAfee experts.
    • Stay connected to product conversations that matter to you.
    • Participate in product groups led by McAfee employees.
    Join the Community
    Join the Community