cancel
Showing results for 
Search instead for 
Did you mean: 

McAfee Client Proxy Not Redirecting to Proxy

Jump to solution

We use MCP 1.1.0.28, SaaS Web Control Panel, and the latest version of EPO.

I am using a test laptop and It's always reporting "No Redirection".

Our MCP policy in ePO is setup to redirect when off premises:

Screen1.jpg

I have verified that the Policy and revision are the same. In EPO:

Revision.jpg

On the Laptop:

RevisionLaptop.jpg

I have tested from the laptop to make sure I can not hit those servers. I am not able to hit those servers and ports. I can hit them when I am on the network. You will notice that it shows no redirection and no connectivity. I'm assuming the no connectivity just means its not going to hit the proxy server? When I am on the network it shows the active proxy.

I have checked the registry and it just shows the same information.

Any idea what the issue is or what else I can look at? Why is the policy not using the proxy server when I am off the premises?

1 Solution

Accepted Solutions
McAfee Employee jscholte
McAfee Employee
Report Inappropriate Content
Message 3 of 12

Re: McAfee Client Proxy Not Redirecting to Proxy

Jump to solution

Hi Nate and Thorsten,

You need MCP 1.1 hotfix 1, please open a support case and request it. Open it with the Web Gateway team.

There is a change in behavior from 1.0 to 1.1 where if the captive portal check fails, MCP will not redirect, this was problematic and reverted quickly.

Best,

Jon

11 Replies
Reliable Contributor Troja
Reliable Contributor
Report Inappropriate Content
Message 2 of 12

Re: McAfee Client Proxy Not Redirecting to Proxy

Jump to solution

Hi nate.hall,

do you have any solution for you problem??

I also have a problem with MCP:

- There is no internet access for my client

- MCP is configured to redirect any network traffic to a mcafee mwg

- The proxy is reachable from the client

In this case MCP is not redirection any traffic.

Has anyone seen the same behavior?

Cheers,

Thorsten

McAfee Employee jscholte
McAfee Employee
Report Inappropriate Content
Message 3 of 12

Re: McAfee Client Proxy Not Redirecting to Proxy

Jump to solution

Hi Nate and Thorsten,

You need MCP 1.1 hotfix 1, please open a support case and request it. Open it with the Web Gateway team.

There is a change in behavior from 1.0 to 1.1 where if the captive portal check fails, MCP will not redirect, this was problematic and reverted quickly.

Best,

Jon

Reliable Contributor Troja
Reliable Contributor
Report Inappropriate Content
Message 4 of 12

Re: McAfee Client Proxy Not Redirecting to Proxy

Jump to solution

Hi Jon,

perfect, got the patch from Support. Anything fine now. 🙂

Cheers,

Thorsten

Re: McAfee Client Proxy Not Redirecting to Proxy

Jump to solution

I also got the patch (1.1.1.2) and I am still not getting redirected to the proxy.

MCP.jpg

Highlighted
kwidhalm
Level 11
Report Inappropriate Content
Message 6 of 12

Re: McAfee Client Proxy Not Redirecting to Proxy

Jump to solution

Hi Nate,

Have you contacted Support regarding this issue?  Do you have a service request number that I can follow up on?

Best regards,

Karen W.

SaaS Email and Web Security Technical Support

McAfee Employee jscholte
McAfee Employee
Report Inappropriate Content
Message 7 of 12

Re: McAfee Client Proxy Not Redirecting to Proxy

Jump to solution

Looks like there is one open which is activley being worked on.

Best,

Jon

McAfee Employee jscholte
McAfee Employee
Report Inappropriate Content
Message 8 of 12

Re: McAfee Client Proxy Not Redirecting to Proxy

Jump to solution

Oh, just a thought, its not a good idea to have your corporate network detection checks on port 80. Most times MCP may stand down because of a captive portal responding. So that could be the issue...

Best,

Jon

Re: McAfee Client Proxy Not Redirecting to Proxy

Jump to solution

Jon,

Unfortunately removing the server that was using port 80 did not fix it. I then tested it with "Always redirect" and it still wasn't pointing to the proxy.

McAfee Employee jscholte
McAfee Employee
Report Inappropriate Content
Message 10 of 12

Re: McAfee Client Proxy Not Redirecting to Proxy

Jump to solution

It sounds like there is a problem talking with the proxy which would prevent MCP from standing up.

Gather a wireshark capture from the client when you have the problem (with always redirecting enabled) and post it to that case. Also send in the MCP folder:

-MCP Folder

   # Windows XP

   C:\Document and settings\All Users\Application Data\McAfee\MCP

   # Windows 7/Vista

   C:\ProgramData\McAfee\MCP

Do not post it here, put it on the case.

Best,

Jon

More McAfee Tools to Help You
  • Subscription Service Notification (SNS)
  • How-to: Endpoint Removal Tool
  • Support: Endpoint Security
  • eSupport: Policy Orchestrator
  • Community Help Hub

      New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

    • Find Forum FAQs
    • Learn How to Earn Badges
    • Ask for Help
    Go to Community Help

    Join the Community

      Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

    • Get helpful solutions from McAfee experts.
    • Stay connected to product conversations that matter to you.
    • Participate in product groups led by McAfee employees.
    Join the Community
    Join the Community