cancel
Showing results for 
Search instead for 
Did you mean: 

silent install 5.2 fails - windows installer pops up

Hi,

I am trying to install vssetup (5.2) on our XPSP3 systems (full admin rights), via a batchfile that looks like this:

xcopy "J:\INSTALL\APPS\mcafee\silent" "C:\" /E /C /R /Y
cd\
cd /D C:
VSSETUP.EXE /CK=[our key here]  /P=VFB

so it copies first the vssetup to the C: drive, then executes it ; at first I tried also to run it straight from the server, add other parameter like /Policyid=[our policy here] and /ScanComputer

each time, I get the pop-up window of the Windows Installer (see attached), as if somewhere within the installer it was not able to interpret an msiexec parameter?

I click on OK to close the pop-up, then it pops up again another time, then the install seems to finish, but the product is not installed, the McAfee program files group is empty.

I have tried to run it manually via the RUN, or copied it manually to the pc, or even changed the temp variables to C:\Temp (thinking it was a temp issue) ....but no avail, same issue

BUT when I try to install via a URL-based install, I do get the Windows Installer popup once, but then the install does end successfully and the product is installed normally

This issue with the silent install happens on any of our machines, unfortunately we have no AD, so I have to rely on the silent package to install on +200 pc's

any help or ideas would be much appreciated!

Thanks

Olivier

2 Replies
Briggs
Level 7
Report Inappropriate Content
Message 2 of 3

Re: silent install 5.2 fails - windows installer pops up

Here is my batch file to install, maybe you can modify it to work for your environment.

IF NOT EXIST "C:\Program Files\McAfee" (
goto install
:Install
Echo Installing McAfee Anti Virus
MD %systemdrive%\mcafeeinstall\
xcopy "\\servername\Software deployment\McAfee\*.*" /c /r /y /i %systemdrive%\mcafeeinstall\
c:
c:\mcafeeinstall\vssetup.exe /CK=XXXXXXXXXXXX /Email=XXXXXX@XXXX.com /P=V
rmdir /s /q "C:\mcafeeinstall"


) ELSE (
echo McAfee installed
)

Re: silent install 5.2 fails - windows installer pops up

Hi,

thanks for your reply, but the issue is not with the batchfile, it is somewhere within the vssetup that it goes wrong, more specifically in phase 10 of the setup, which according to the vssetup.log is supposed to do :

10 SetupUsrSrvr

but when I check what happens in the log is this:

Install phase 10
VsSetup.Exe, ### --------------
VsSetup.Exe, ### Some error occured and we are unwinding the installation.

see the log attached

best regards

Olivier