cancel
Showing results for 
Search instead for 
Did you mean: 
sameer172006
Level 12

SaaS Endpoint Suite BROWSER Protection INCOMPATIBLE with FF4.0 and Chrome ??? What about the Web Filtering Service then ?

Hi,

I have been quite dormant on the community scene owing to increasing work. Last week, I happened to migrate to the latest versions of the browsers :- IE 9. Firefox 5.0 and Chrome 12.0.

I had thought McAfee SaaS team would keep up the momentum with the browser wars and the evergreen updates and make sure that the BROWSER Protection of the suite does live up to its name and offer what it says it would :- BROWSER PROTECTION !!! Remember... This is supposed to be the ALWAYS ON, ALWAYS UPDATED SECURITY SOFTWARE ??? SaaS ? Cloud ?

Well, the sad part is, McAfee SaaS Endpoint Protection Suite still lags behind and is stuck with Site Advisor version 3.0.602 which does NOT work with either Google Chrome or even FF 4.0 . So what is the use of having such a useless component ? It will run in the services, use the memory but do NOTHING. Does McAfee expect us users to lag behind and use the old and outdated browsers so that it can do us a favour by saying that yeah, we can protect you with the older versiosn

I am a die hard fan and a loyal user of McAfee and will leave no stone unturned to vent out my opinion  the negative areas which will have a lot of BAD impact on the users. Just think about people who PAID money to get eb filtering services from this suite and guess what ? That very component is INCOMPATIBLE !

PLEASE integrate the newer versions of the Site Advisor ( 3.3)  which are compatible with the new browsers and make sure that you live up to the promise of giving COMPLETE ENDPOINT PROTECTION. This suite is supposed to be a full blown suite and it is your duty to make sure that all the incompatible components do get updated. PLEASE pay heed and work on this ASAP. Browser Protection is very important in helping the users against phishing and also the very important web filtering aspect.

I will look forward to some urgent remedy to this issue. Its very late though but McAfee can still buck up!!!

S.A.M.E.E.R

0 Kudos
13 Replies
rchella1
Level 7

Re: SaaS Endpoint Suite BROWSER Protection INCOMPATIBLE with FF4.0 and Chrome ??? What about the Web Filtering Service then ?

Hi Sameer,

We certainly have prioritized the issues that you have addressed to us with the product and are working on the same. We are expecting possible fix in the next patch release which is 5.2.2 during the 1st or 2nd week of August.  We assure you that we are constantly working to upgrade the product to meet all  your requirements , keeping in pace with the advancements in the OS  and updates that are happening with different browser versions day by day.

Also, Site Advisor is not compatible with the new browser version (Firefox, Google Chrome etc.,). With the next patch (5.2.2), we are expecting some of the IE9 issues with Site Advisor might get resolved. We are closely working with Engineering team to update it in future.

Regards,

Raajesh C.

0 Kudos
sameer172006
Level 12

Re: SaaS Endpoint Suite BROWSER Protection INCOMPATIBLE with FF4.0 and Chrome ??? What about the Web Filtering Service then ?

Hi Rajesh,

My reaction and the state of mind after reading your reply ranged from shocked to stunned and not to mention the various jolts that each of your sentence gave to me.

Though I thank you for paying heed to the post and actually taking the pain and ownership to reply but my friend you are talking about a new release for the month of August as if its happening tomorrow.

You mentioned Site Advisor is not compatible with FF and Chrome. I mean , really ?? Well, how about this  then ?

http://www.siteadvisor.com/download/windows.html

Please visit that link to read about how Site Advisor works with IE, FFand chrome and yes, includes all the latest versions. I know, now you would tell me Site Advisor free is different than SA Enterprise but come one isnt the CORE product the same - SITE ADVISOR ?

Also, even for the SA Enterprise, the patch 3 was rolled out last month and hasnt percolated down to the SaaS suites yet. I wonder why. All premium SaaS flavours offer Web filtering and it kinda surprises  me to no end to see that you are so cool and casual about the fact that it just doesnt support FF and Chrome then why is it that the Web filtering is being offered with suchsuites ? Whats the point ?

I reiterate, I eat, live and think McAfee and SaaS product is some howvery very close to my heart. I appreciate the fact that the McAfee P.D team did take into consideration my earlier requests and FMR s but please take a re look into the Site Advisor thing. The 5.2.2 will come when it comes but mean while atleast roll out the patch 3 for S.A.

Is that too much to be asked ? Guess not !

0 Kudos
rchella1
Level 7

Re: SaaS Endpoint Suite BROWSER Protection INCOMPATIBLE with FF4.0 and Chrome ??? What about the Web Filtering Service then ?

Hi Sameer,

We value your feedback and suggestions. We have put this across to the Engineering team and would update you about the same regarding the progress.

Please do refer to the KB71532 to validate the actions.

https://kc.mcafee.com/corporate/index?page=content&id=KB71532

Thank you,

Raajesh C.

0 Kudos
sameer172006
Level 12

Re: SaaS Endpoint Suite BROWSER Protection INCOMPATIBLE with FF4.0 and Chrome ??? What about the Web Filtering Service then ?

Thank you

0 Kudos
gigatech
Level 7

Re: SaaS Endpoint Suite BROWSER Protection INCOMPATIBLE with FF4.0 and Chrome ??? What about the Web Filtering Service then ?

its now 2012 and still nothing....

SAE+ 3.0.0.638 is packaged with SaaS, so we cant even rollout the latst 3.5 for chrome support, well done McAfee... it really is a joke

https://kc.mcafee.com/corporate/index?page=content&id=KB51244

SiteAdvisor browser support
IMPORTANT: Only 32-bit browsers are supported. 64-bit browsers are not supported with SAE+ 3.0 and SAE 1.7. SAE 3.5 supports 64 bit versions of browser.

BrowserSAE 1.0SAE 1.5SAE 1.6SAE 1.7SAE+ 2.0

SAE+ 3.0

SAE 3.5

Microsoft Internet Explorer 9.0

EOLEOLEOL

EOL

EOLYes**Yes

Microsoft Internet Explorer 8.0

EOL

EOL

EOL

EOL

EOL

YesYes

Microsoft Internet Explorer 7.0

EOL

EOL

EOL

EOL

EOL

YesYes

Microsoft Internet Explorer 6.0

EOL

EOL

EOL

EOL

EOL

Yes*

Yes††

Microsoft Internet Explorer 5.5

EOL

EOL

EOL

EOL

EOL

No

No
Mozilla Firefox 10.xEOLEOLEOLEOLEOLNo

No

Mozilla Firefox 9.xEOLEOLEOLEOLEOLNo

No

Mozilla Firefox 8.x

EOL

EOL

EOL

EOL

EOL

No

No

Mozilla Firefox 7.x

EOL

EOL

EOL

EOL

EOL

No

No

Mozilla Firefox 6.x

EOL

EOL

EOL

EOL

EOL

No

No

Mozilla Firefox 5.xEOLEOLEOLEOLEOLNoNo
Mozilla Firefox 4.x

EOL

EOL

EOL

EOL

EOL

No ***

Yes
Mozilla Firefox 3.x

EOL

EOL

EOL

EOL

EOL

Yes

Yes

Mozilla Firefox 2.0

EOL

EOL

EOL

EOL

EOL

Yes

No
Mozilla Firefox 1.5

EOL

EOL

EOL

EOL

EOL

Yes

No
Google Chrome

EOL

EOL

EOL

EOL

EOL

No

Yes

Support for Firefox 5 and later will be provided in SiteAdvisor 3.5 Patch 1.  This article will be updated when that is posted to the McAfee download site. For details of the known issue, see KB51244.

†† Requires XP SP2 or higher.

* Microsoft Internet Explorer 6.0 with SP1 or later

** Requires SiteAdvisor Enterprise 3.0 Patch 3.

*** For support information on Firefox 4, see KB71532.

0 Kudos
zoli62
Level 7

Re: SaaS Endpoint Suite BROWSER Protection INCOMPATIBLE with FF4.0 and Chrome ??? What about the Web Filtering Service then ?

Unfortunately McAfee has not fully supported Firefox, see other similar  issue here https://community.mcafee.com/message/232948#232948  for this reason, I also use the free SiteAdvisor instead of the built-in.

0 Kudos
Pritish
Level 11

Re: SaaS Endpoint Suite BROWSER Protection INCOMPATIBLE with FF4.0 and Chrome ??? What about the Web Filtering Service then ?

Hi All,

As of now we do not have an ETA as when McAfee will support FireFox browsers greater than the 3.6 and the other browsers like the Google chrome.

Once we get to know the details we will update here. Sorry for the inconvenience.

Regards

Pritish P.

0 Kudos
zoli62
Level 7

Re: SaaS Endpoint Suite BROWSER Protection INCOMPATIBLE with FF4.0 and Chrome ??? What about the Web Filtering Service then ?

What does mean ETA?

0 Kudos
rchella1
Level 7

Re: SaaS Endpoint Suite BROWSER Protection INCOMPATIBLE with FF4.0 and Chrome ??? What about the Web Filtering Service then ?

Hi Zoli,

ETA mean Expected Turn Around time.

Regards,

Raajesh C.

0 Kudos