cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
jharpj
Level 7
Report Inappropriate Content
Message 1 of 8

Firewall prevents Spysweeper auto updates

McAfee firewall is preventing My Spy sweeper for MSN program from updating automatically. This is evidenced by the fact that I continue to receive messages from Spy sweeper stating that it failed to update. When I disable McAfee firewall then manually update Spy sweeper there is no problem.

How do I tell McAfee that it is okay to allow Spy sweeper to download updates automatically ??
Thank you in advance.
7 Replies

RE: Firewall prevents Spysweeper auto updates



I am not familiar with "My Spy sweeper for MSN", however, if you are referring to Spy Sweeper (by Webroot), the problem may lie in the firewall permissions. The latest releases (version 6. . . ) seem to require "Full Access" (rather than "Outbound-only Access". Further, the newest versions have three(3) distinct modules ("SpySweeper.exe", "WRConsumerService.exe" and "SSU.exe") which may require firewall permissions.

One question: can you manually update "Spy Sweeper" with the firewall enabled (as opposed to awaiting automatic update) ?
jharpj
Level 7
Report Inappropriate Content
Message 3 of 8

Firewall prevents Spysweeper auto updates

Yes, this is Spysweeper by Webroot.
I can only update by disabling McAffe's firewall. Currently when ever Spysweeper attempts to update automaticly it gives me a popup stating that it was unable to update. It would seem there should be some way to tell the firewall to allow Spysweeper to update.

RE: Firewall prevents Spysweeper auto updates

Webroot Spysweeper has always had issues with McAfee and vice versa.

You would have to ask them what permissions are needs in the firewall but you can probebly add it yourself.

Double-click the taskbar icon to open SecurityCenter
Click Advanced Menu (bottom left)
Click Configure (lower left)
Click Internet & network (top left)
Click Advanced (right)

Under the Security Level tab (left) you have two alternatives, either adjust the slider to "Standard" which will then make it ask you for permission by default when something seeks access or you can check the "Allow Full Access" button. Click Apply.

and/or..

Click Program Permissions (left)

Find Spysweeper and click "Allow Access" to give it full access. You can also add other Spysweeper processes to that list, allowing full access to each.
jharpj
Level 7
Report Inappropriate Content
Message 5 of 8

Firewall prevents Spysweeper auto updates (Ex-Brit)

Ex-Brit,
Thank you for your reply to my problem, here are the results from following your suggested solutions -

1. The security level tab was already set for "Standard'.
2. Clicking the "Allow Full Access" button, sounds like it would allow anything and everything full access thus defeting the purpose of a firewall. (????) So I am hesitant to do that without more knowledge.
3. The permissions were already set to allow Spysweeper full access.
4. I have no clue how to add other Spysweeper processes to that list.

RE: Firewall prevents Spysweeper auto updates (Ex-Brit)

Well you shouldn't need to alter that particular setting.
Well, looking at Webroot's help pages I came across this one: http://support.webroot.com/cgi-bin/webroot.cfg/php/enduser/std_adp.php?p_faqid=377&p_created=1188940...
Which reads in part:

 


If your firewall or antivirus program is blocking Spy Sweeper/Webroot AntiVirus/Webroot Internet Security Essentials from accessing the Internet to authenticate the keycode or download security definitions, you need to go into your firewall and/or antivirus permissions and add the following Webroot software components found in the Webroot installation directory:

SpySweeper.exe
SpySweeperUI.exe
SSU.exe
WRConsumerService.exe


If you need further assistance with your firewall or security software, please contact the software manufacturer for your firewall or security program. If you need further support, please create a ticket or reopen your existing ticket by clicking here.


To allow thos items through the firewall go to my instructions above regarding Program Permissions and add them giving full access.

Double-click the taskbar icon to open SecurityCenter
Click Advanced Menu (bottom left)
Click Configure (lower left)
Click Internet & network (top left)
Click Advanced (right)

Click Program Permissions (left)

Click "Add Allowed Program" and locate the above processes which will most likely be in the ProgramFiles folder on your hard drive.

If you can't figure out how to do it, then please contact our Technical Support Chat and ask them, they can probably do it for you. Link at top left of this page or in my signature.
jharpj
Level 7
Report Inappropriate Content
Message 7 of 8

Halleluiah -

Halleluiah -
The problem appears to have been corrected thanks to your most recent instructions.
Your time and patience is sincerely appreciated.

RE: Firewall prevents Spysweeper auto updates

Glad to help, good luck.
How Many Badges Can You Collect?
Ready for a little competition? Members like you are earning badges and unlocking perks for their helpful answers. Are you? Click here to find out.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community