cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted

Deployment Failure

i got error when i check in system faults.

I do not know how to resolve it. Could you please help me ?

Condition Type:Alarm Type:Severity:Last Occurrence Time:Acknowledged:Additional Text:Creation Time:

SignatureUpdateFAIL
Communication
Critical
2019-Dec-25 10:36:44 GMT+07:00
 
The attempt by the Manager to deploy pending changes to device VFDC-IPS-NS7250-01 failed. Please consult the system log for details. (The Manager will continue to attempt deployment until it is successful.). Fail reason: Reason #42: Sensor fails to apply new updates internally
2019-Dec-17 10:19:01 GMT+07:00
7 Replies
Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 8

Re: Deployment Failure

Hi @huytq1786

From the error, it looks the deployment process has stuck hence the manager is unable to push the new signature/configuration. You may check the deployment progress via command downloadstatus and let us know the output.

 

If there is no progress we might want to reboot the Sensor, that can be confirmed from the above command output.

 

 

 

Regards,
Faizan

Was my reply helpful?
If you find this post useful, please give it a Kudos! l Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!
Highlighted

Re: Deployment Failure

Dear Mr. Faizan

Thank you for your suggestion.

Here is the result of downloadstatus on my sensor

[Download Status]
--------------------
Signatures Downloaded : 2802
Last Signature Download Status : bad
failure cause = unknown
Last Signature Download Type : SIGSET + POLICY
Certificates Downloaded : 0
DAT Files Downloaded : 219
Last DAT File Download Status : good
Last DAT File Download Time (UTC) : 17:2:41, 12/29/2019
CRLSET Files Downloaded : 0
Software Upgrades : 0
DoS Profile Downloads from Manager : 0
DoS Profile Uploads to Manager : 796
Last DoS Profile Upload Status : good
Last DoS Profile Upload Time (UTC) : 17:2:35, 12/29/2019
Diagnostic Trace Requests : 0
Guest Portal SSL Cert Downloads from Manager : 0
Guest Portal SSL CSR Uploads to Manager : 0
IBAC AD file Downloads from Manager : 0
IBAC AD file Uploads to Manager : 1
Last IBAC AD file Upload Status : good
Last IBAC AD file Upload Time (UTC) : 9:29:2, 11/23/2018
Offline downloads to sensor : 0
Device Profile update count : 0
User Id Acl Bulk File download count : 0

Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 4 of 8

Re: Deployment Failure

Hi @huytq1786 

It is quite unclear why the deployment is failing. Kindly reach out to the Support Team with Info-collector & Sensor trace file to identify if it is a sensor issue or Manager issue and proceed accordingly.

Regards,
Faizan

Was my reply helpful?
If you find this post useful, please give it a Kudos! l Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!
Highlighted

Re: Deployment Failure

Hi fkazi04,  huytq1786

I have the same error now. 

Do you have a solution to this problem?

 

Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 6 of 8

Re: Deployment Failure

Hi @Havanhung 

Reason #42: Sensor fails to apply new updates internally - this fault will be triggered when the Sensor doesn't have sufficient memory to push the latest signature and fails.

We have 2 options here:

1. Workaround: download & import lite signature manually 

2. Permanent fix: upgrade the Sensor software to minimum recommended version

Kindly follow below KB for more details:

https://kc.mcafee.com/corporate/index?page=content&id=KB87554

Regards,
Faizan

Was my reply helpful?
If you find this post useful, please give it a Kudos! l Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!
Highlighted

Re: Deployment Failure

Hi faizan!

I am having same issue that comes after upgrading to version 9.2.5.163 latest release on NS 9100 sensor.I am not able to ssh the sensor and sensor stays in BAD health all time.

Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 8 of 8

Re: Deployment Failure

Hi @User27622125 

There are many possibilities for bad health like - signature missing, internal process crash for various reason.

You can try below steps in following order:

1. If the Sensor is connected with NSM, try deploying signature.

2. If the Sensor is disconnected, perform power cycle (cold boot)

If there is a minor glitch the health should be recovered following above steps.

 

Worst case scenario would be a re-image of the Sensor. Kindly reach out to the Support Team to confirm if re-image is required.

 

Regards,
Faizan

Was my reply helpful?
If you find this post useful, please give it a Kudos! l Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!
You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community