cancel
Showing results for 
Search instead for 
Did you mean: 

ePO Endpoint Deployment Kit 9.6.1 - cant get .msi package installed

Hi, I try to install a .msi package via EEDK.

Everythings look good, I used the .bat wrapper.

The setup seems to run on the system but starts -3- msiexec instances at once, blocking the whole installation process. I can run the installation manually on the client using the same line of code.

This is my installer.bat:

 

@echo off

:: Get number of input parameters

set argC=0

for %%x in (%*) do Set /A argC+=1

:: Stuart Avery McAfee, Inc. 2011


:: ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

:: Torry Campbell McAfee, Inc. 2011

:: ################################################

:: Set environment to current product folder

pushd "%~dp0"

:: Get software package source directory and set as variable SRCDIR

SET SRCDIR=

for /f "delims=" %%a in ('cd') do @set SRCDIR=%%a

%comspec% /c %systemroot%\system32\msiexec.exe /i %SRCDIR%\NessusAgent-7.0.3-x64.msi NESSUS_GROUPS="all-agents" NESSUS_SERVER="xxxxxxx:8834" NESSUS_KEY=xxxxxxx /qn /L*v c:\nessuslog.log


goto EOF

:: Exit and pass proper exit to agent

:: ################################################

:EOF

Exit /B 0
1 Reply
Highlighted

Re: ePO Endpoint Deployment Kit 9.6.1 - cant get .msi package installed

Forgot to mention, at the moment it always results in a msiexec.exe process with parameter /V.

I used Sysinternals Procmon to check.

Since there is no /V in my script and /V is an invalid option, I have no idea how to fix that.

 

c:\windows\system32\msiexec.exe /V

 

 

I also tried to run the .msi without any parameter, same result.

Running the package from cmd.exe on the machine does a clean install.

Member Rewards
McAfee Community rewards active and helpful members just like you. Click here to take a look at the first community members who received a special reward and were recognized by McAfee leader, Aneel Jaeel, for their participation and trusted knowledge in the community.