cancel
Showing results for 
Search instead for 
Did you mean: 

Change Administrator Password

Jump to solution

Upon logging into our firewall today, through the admin console, I was forced to change the Administrator password.  I cannot find anywhere to disable this.  I would like to keep the same password in all of our devices for management purposes.  Is this something that can be disabled?  If so how?  Or is this just something that we must live with?  This is a s2008 appliance with the latest software I think it is 8.03P01  but I know it is the latest version.  Thanks for your help.

1 Solution

Accepted Solutions
PhilM
Level 14
Report Inappropriate Content
Message 2 of 5

Re: Change Administrator Password

Jump to solution

In older versions (pre v7) I believe it was possible to configure the local authentication server service to disable enforced password changing.

However, since v7, you are no longer able to do this.

The compromise option is to go to the settings screen for the "Password" authentication service and increase the expiry value to the largest value it will accept.

You need to go to Policy --> Rule Elements --> Authentiators, select the Password authenticator service to change this value.

Ironically, while logging into my v8 appliance to check this setting I was forced to change my password! I personally don't have an issue with doing so, but not being able to do so using SSH is a bit of a pain because it doesn't actually tell you that the password has expired - just that it is no longer valid.

-Phil.

View solution in original post

4 Replies
PhilM
Level 14
Report Inappropriate Content
Message 2 of 5

Re: Change Administrator Password

Jump to solution

In older versions (pre v7) I believe it was possible to configure the local authentication server service to disable enforced password changing.

However, since v7, you are no longer able to do this.

The compromise option is to go to the settings screen for the "Password" authentication service and increase the expiry value to the largest value it will accept.

You need to go to Policy --> Rule Elements --> Authentiators, select the Password authenticator service to change this value.

Ironically, while logging into my v8 appliance to check this setting I was forced to change my password! I personally don't have an issue with doing so, but not being able to do so using SSH is a bit of a pain because it doesn't actually tell you that the password has expired - just that it is no longer valid.

-Phil.

View solution in original post

Re: Change Administrator Password

Jump to solution

Thanks for the info.  It would be nice if this was an option that you could turn off if you wanted.

Highlighted
sliedl
Level 14
Report Inappropriate Content
Message 4 of 5

Re: Change Administrator Password

Jump to solution

Go to Authenticators and click on Password and change the Expiration to 99999999 and your passwords will not expire for around 273972 years (that's not exact though, because of intercalation).

Re: Change Administrator Password

Jump to solution

Thanks I think that will work.  I hope to be retired by then

More McAfee Tools to Help You
  • Subscription Service Notification (SNS)
  • How-to: Endpoint Removal Tool
  • Support: Endpoint Security
  • eSupport: Policy Orchestrator
  • Community Help Hub

      New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

    • Find Forum FAQs
    • Learn How to Earn Badges
    • Ask for Help
    Go to Community Help

    Join the Community

      Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

    • Get helpful solutions from McAfee experts.
    • Stay connected to product conversations that matter to you.
    • Participate in product groups led by McAfee employees.
    Join the Community
    Join the Community