cancel
Showing results for 
Search instead for 
Did you mean: 
finetbeau
Level 7

Newbie to community ....malware/spyware issue

I have noticed that in attempting to open some sites (even those with green McAfee checkmark), I am redirected elsewhere via ihavetnet.com. Total Security is up to date and has not picked it up. Fifefox (up to date) is my browser. Operating system is Vista.  Where do I start?

Any assistance would be greatly appreciated.

Thanks in advance!

0 Kudos
2 Replies
exbrit
Level 21

Re: Newbie to community ....malware/spyware issue

Moved this to Malware Discussions.

Can you use System Restore to go back to before this all started?   If necessary it can be invoked from Safe Mode.

If not try scanning with some extra tools - see the last link in my signature below.

Perhaps Stinger and Malwarebytes Free.   To keep the latter free of charge do NOT accept the free trial offer.

0 Kudos
Hayton
Level 17

Re: Newbie to community ....malware/spyware issue

The "IHaveNet" browser redirect is well-known and all the forums are full of complaints about it. Amazingly their website has a Green rating on both SiteAdvisor and WOT.

The first step is to check Firefox add-ons for anything that's been installed without permission, and to look in the  list of programs on the PC for anything that shouldn't be there. Task Manager or Process Explorer should show any rogue processes, and AutoRuns will show all the programs and processes that run at startup and login.

AdwCleaner might be useful here, and so should Malwarebytes.

0 Kudos