cancel
Showing results for 
Search instead for 
Did you mean: 
zongo
Level 7
Report Inappropriate Content
Message 1 of 1

Segmentation Fault when running nails-update

# /opt/NAI/LinuxShield/libexec/nails-update

Segmentation fault

Environment:

CentOS 7

vsel - 2.0.2 - Installed with task.

MA - 4.8.0.1938 - Installed via ePO server script

ePO: 5.1.2 running on Windows 2012 R2 bare metal

Agent is managed

strace has been attached 'nai.out'.

ldd /opt/NAI/LinuxShield/libexec/nails-update

linux-vdso.so.1 =>  (0x00007fff55d99000)

libicui18n.so.38 => not found

libicuuc.so.38 => not found

libicudata.so.38 => not found

libssl.so.1.0.0 => not found

libcrypto.so.1.0.0 => not found

libxml2.so.2 => /lib64/libxml2.so.2 (0x00007f9ea300e000)

libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f9ea2df2000)

libdl.so.2 => /lib64/libdl.so.2 (0x00007f9ea2bed000)

libtirpc.so.1 => not found

libstdc++.so.6 => /lib64/libstdc++.so.6 (0x00007f9ea28e6000)

libm.so.6 => /lib64/libm.so.6 (0x00007f9ea25e3000)

libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007f9ea23cd000)

libc.so.6 => /lib64/libc.so.6 (0x00007f9ea200c000)

libz.so.1 => /lib64/libz.so.1 (0x00007f9ea1df5000)

liblzma.so.5 => /lib64/liblzma.so.5 (0x00007f9ea1bd0000)

/McAfee/lib/ld-intelsecurity.so.2 => /lib64/ld-linux-x86-64.so.2 (0x00007f9ea3381000)

Why am I getting a segfault? The expectation here is that I should be able to run #nails-update as the binary is installed without getting the seg fault.

I can't help noticing the missing libraries. Is it normal Doctor?