cancel
Showing results for 
Search instead for 
Did you mean: 
thebox
Level 8
Report Inappropriate Content
Message 1 of 4

Pushing Agent from ePO to OS X fails, permissions issue, what do I need to fix?

Jump to solution

Hey all,

I can't push agents to OS X machines and I am hoping someone could tell me what I need to do change.  The log in ePO showing the failure:

10/22/14 3:22:33 PM

SSH Output: Connected to [host IP address]

10/22/14 3:22:33 PM

SSH Output: Sending file install.sh

10/22/14 3:22:33 PM

SSH Output: pscp: unable to open install.sh: permission denied

10/22/14 3:22:33 PM

SSH Output: Sent EOF message

10/22/14 3:22:33 PM

SSH Output: Server sent command exit status 0

10/22/14 3:22:33 PM

SSH Output: Disconnected: All channels closed

10/22/14 3:22:33 PM

Error copying file C:\Windows\TEMP\mfe484909890.tmp\install.sh to [host IP address], system error: 1

I have an active directory group that has access to admin the machine, and the account being used to push the agent is a member of that group, which also has remote login access to the machine.  I obviously missed something but I don't know what I need to change, and I am pretty new to OS X so it could be something obvious...

Using ePO 5.1 with agent version, 4.8.0.1816, testing with OS X Mavericks and Yosemite machines, both seeing same results.

I would appreciate some ideas!

Thanks!

1 Solution

Accepted Solutions
thebox
Level 8
Report Inappropriate Content
Message 3 of 4

Re: Pushing Agent from ePO to OS X fails, permissions issue, what do I need to fix?

Jump to solution

i dunno if there is a way around this, but i discovered in my case that i am able to push the agent to OS X just fine, but only if the user account that is pushing the agent has a cached profile.  doesn't really help my deployment at this point but at least it will work...

3 Replies

Re: Pushing Agent from ePO to OS X fails, permissions issue, what do I need to fix?

Jump to solution

same issue here.

any hint would be apreciable. i did enable SSH on the mac, and configure the install account to be an admin on the mac..

what's puzzling me, is that it is trying to copy a file in c:\windows\temp ??

for real?

mac doesn't have c:\windows..

is this a bug in the agent install procedure?

thebox
Level 8
Report Inappropriate Content
Message 3 of 4

Re: Pushing Agent from ePO to OS X fails, permissions issue, what do I need to fix?

Jump to solution

i dunno if there is a way around this, but i discovered in my case that i am able to push the agent to OS X just fine, but only if the user account that is pushing the agent has a cached profile.  doesn't really help my deployment at this point but at least it will work...

Re: Pushing Agent from ePO to OS X fails, permissions issue, what do I need to fix?

Jump to solution

brilliant, that did the trick!

thank's a lot.