cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 1 of 3

Microsoft WSL (Windows Subsystem for Linux) is not working with ENS 10.7.x

Jump to solution

I have a system admin saying that McAfee ENS Threat Prevention 10.7 May Update is preventing the Microsoft WSL from running. I came across a new KB article KB91411 that states that McAfee ENS 10.x is not supported with WSL due to compatibility issues. It states that they are investigating for a future release. 

Also noticed that there is a Access Protection rule called Windows Subsystem for Linux and it is set to block. If they don't support it then why the rule as it makes you wonder that it you uncheck the block will it then work and if so what other issues will there be. 

 

Does anyone know when that will be as we have people wanting to use this Windows Subsystem for Linux.

1 Solution

Accepted Solutions
Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 3

Re: Microsoft WSL (Windows Subsystem for Linux) is not working with ENS 10.7.x

Jump to solution

Hello @twenden 

As you see in KB91411, with this feature being unsupported, we can't guarantee correct products behaviour.
To my knowledge, there is no information as to which version it would support. You can submit a new Service Request to McAfee Support to confirm to McAfee development team.

Thanks,

Was my reply helpful?

If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

View solution in original post

2 Replies
Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 3

Re: Microsoft WSL (Windows Subsystem for Linux) is not working with ENS 10.7.x

Jump to solution

Hello @twenden 

As you see in KB91411, with this feature being unsupported, we can't guarantee correct products behaviour.
To my knowledge, there is no information as to which version it would support. You can submit a new Service Request to McAfee Support to confirm to McAfee development team.

Thanks,

Was my reply helpful?

If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

View solution in original post

Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 3 of 3

Re: Microsoft WSL (Windows Subsystem for Linux) is not working with ENS 10.7.x

Jump to solution

Hello,

Please check your logs, there is maybe an Access Protection rule that blocks this. 

 

start.jpg

The KB is more about the filtering inside this Subsystem which is not supported - so you have no detection inside this WSL.

 

Kind regards,

Stefan

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community