cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Former Member
Not applicable
Report Inappropriate Content
Message 1 of 3

Error Deploying EndPoint Security 10.7 to RHEL 7.7 Machine

Jump to solution

Hello - ePO successfully deployed ENS 10.7 to several RHEL 7.7 machines but we have one machine that consistently fails to install.  The agent successfully installed and ePO can see it.

I looked through the logs and see the following:

"Invoking events with EventId " 0" Severity "4" Type: Install, State 9 Error: 40019 Specify a different directory that has the required permissions. You do not have the permissions to run the installation script on path /var/McAfee/agent/update/Current/ENDP_AM_1070LNYX/Install/0409"

Note on this machine, it's the only machine that requires me to enter my password when I ssh into it. 

1 Solution

Accepted Solutions
Former Member
Not applicable
Report Inappropriate Content
Message 2 of 3

Re: Error Deploying EndPoint Security 10.7 to RHEL 7.7 Machine

Jump to solution

its possible that the /var partition has noexec set on it and that is preventing the install script from running.  if that is the case add this variable to the epo install command line and try the install again:

alttmppath=/tmp

or any other folder partitions that you want the install to run from.

what that will do is tell the install to copy the installation files to the /tmp folder and run the install from that folder instead of the /var folder.

another option is to download the 10.7 standalone install zip from the mcafee download site and run the install locally since it is just the one server.  

View solution in original post

2 Replies
Former Member
Not applicable
Report Inappropriate Content
Message 2 of 3

Re: Error Deploying EndPoint Security 10.7 to RHEL 7.7 Machine

Jump to solution

its possible that the /var partition has noexec set on it and that is preventing the install script from running.  if that is the case add this variable to the epo install command line and try the install again:

alttmppath=/tmp

or any other folder partitions that you want the install to run from.

what that will do is tell the install to copy the installation files to the /tmp folder and run the install from that folder instead of the /var folder.

another option is to download the 10.7 standalone install zip from the mcafee download site and run the install locally since it is just the one server.  

View solution in original post

Former Member
Not applicable
Report Inappropriate Content
Message 3 of 3

Re: Error Deploying EndPoint Security 10.7 to RHEL 7.7 Machine

Jump to solution

Perfect.  Used the alternate path in the client task install command line and Installed without any issues.  Thank you!

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community